<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://chuttenblog.wordpress.com/xmlrpc.php">

<title>This Week in Glean: How Long Must I Wait Before I Can See My Data? &#8211; chuttenblog</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel='dns-prefetch' href='//a.teads.tv' />
<link rel='dns-prefetch' href='//prebid.media.net' />
<link rel='dns-prefetch' href='//adserver-us.adtech.advertising.com' />
<link rel='dns-prefetch' href='//fastlane.rubiconproject.com' />
<link rel='dns-prefetch' href='//prebid-server.rubiconproject.com' />
<link rel='dns-prefetch' href='//hb-api.omnitagjs.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//apex.go.sonobi.com' />
<link rel='dns-prefetch' href='//u.openx.net' />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Feed" href="https://chuttenblog.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Comments Feed" href="https://chuttenblog.wordpress.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1625065786h&ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNkdlOxDAMRX+IxNOyDQ+Ib8lihcw4i+KEqn9PWkFVGGB4iXTte7zEMGVhUqwYK2hKTmRqzkeGKRWrLIOjpBVJw3wDO29om5P8GRlOWLMyZ7GqC/un17UuNRbXMwXhbRjlQY6gmye79F8L6KLKDFxnwq2Qj4aaXfowBLReIWFYB9mJTGrGIgidMrMMPl7He26vv0C/D79OuttZzalV4Yq338b+d4miqo+Or+AmfWCjHA5yAOu5bkHxM7u71PLnPR6yulz8D2zKnRFa54LMor/BtyDqawfXS7+E5+Hh9nE83h/vnk7v6qXeRg==?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??/wp-content/mu-plugins/comment-likes/css/comment-likes.css,/i/noticons/noticons.css?m=1436783281j&cssminify=yes' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='hew-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C600italic%2C700italic%7CNoto+Serif%3A400%2C700%2C400italic%2C700italic&#038;subset=latin' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s1.wp.com/_static/??-eJyFj0sOwjAMRC9EMEUqKgvEWUIwqcGJo8ZRxO0JYtOK325G88YfqMk4iYpRIRSTuHiKGTxGnKgFX+Ta5byCWVdHDJghlROMWCHrnfEfRNG9QFOTk/CGz+6pdPaoGbC0VG6Ehm0FxZDYahv5ed/iITEszipJXBhzYUvTr+qEJxbfpIdGzeyzdAyHrt9vul2/HYbrAxlzfR0=?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-5-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='all-css-8-1' href='https://s1.wp.com/_static/??-eJxti0EKgCAQAD+UbVFGHaK3mJgaqyut0vejQ4eo0zAwA2cSmmI2MUMoImGxPjIk4iw2VP4Adurw0T6sNXMF/xeT9goFkqW3fKbsTDAMrgeLtCq8gyXM7dCNUjZy6vcLZTc31Q==?cssminify=yes' type='text/css' media='all' />
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"102555580","siteURL":"http:\/\/chuttenblog.wordpress.com","xhrURL":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"ded3143212","isLoggedIn":"","statusMessage":"","subsEmailDefault":"instantly","proxyScriptUrl":"https:\/\/s0.wp.com\/wp-content\/js\/wpcom-proxy-request.js?ver=20211021","shortlink":"https:\/\/wp.me\/p6Wjog-1B0","i18n":{"followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJzTLy/QTc7PK0nNK9HPKtbPzU/KzEnVLS1OLUpMB4rpZual5etlFevoo6oryinRLSjKr6iEyWXmJeeUpqQWgySzCktTiyqhlF5uZh5BRbq5melFiSWpUMX2ubaGZsbm5gYmJpbmWQCPUzuV'></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chuttenblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/" />
<link rel='shortlink' href='https://wp.me/p6Wjog-1B0' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F12%2F14%2Fthis-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F12%2F14%2Fthis-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="This Week in Glean: How Long Must I Wait Before I Can See My Data?" />
<meta property="og:url" content="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/" />
<meta property="og:description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or wh…" />
<meta property="article:published_time" content="2021-12-14T22:01:14+00:00" />
<meta property="article:modified_time" content="2021-12-14T22:01:14+00:00" />
<meta property="og:site_name" content="chuttenblog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="This Week in Glean: How Long Must I Wait Before I Can See My&nbsp;Data?" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://chuttenblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://chuttenblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://chuttenblog.wordpress.com/osd.xml" title="chuttenblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="chuttenblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://chuttenblog.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean. All “This Week in Glean” blog posts are listed in the&hellip;" />
		<script type="text/javascript">

			window.doNotSellCallback = function() {

				var linkElements = [
					'a[href="https://wordpress.com/?ref=footer_blog"]',
					'a[href="https://wordpress.com/?ref=footer_website"]',
					'a[href="https://wordpress.com/?ref=vertical_footer"]',
					'a[href^="https://wordpress.com/?ref=footer_segment_"]',
				].join(',');

				var dnsLink = document.createElement( 'a' );
				dnsLink.href = 'https://wordpress.com/advertising-program-optout/';
				dnsLink.classList.add( 'do-not-sell-link' );
				dnsLink.rel = 'nofollow';
				dnsLink.style.marginLeft = '0.5em';
				dnsLink.textContent = 'Do Not Sell My Personal Information';

				var creditLinks = document.querySelectorAll( linkElements );

				if ( 0 === creditLinks.length ) {
					return false;
				}

				Array.prototype.forEach.call( creditLinks, function( el ) {
					el.insertAdjacentElement( 'afterend', dnsLink );
				});

				return true;
			};

		</script>
				<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { 'pt': 1, 'ht': 0, 'tn': 'hew', 'uloggedin': 0, 'amp': false, 'consent': __ATA_CC(), 'gdpr_applies': false, 'ad': { 'label': { 'text': 'Advertisements' }, 'reportAd': { 'text': 'Report this ad' } }, 'siteid': 8982, 'blogid': 102555580 };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript">
		(function(){var g=Date.now||function(){return+new Date};function h(a,b){a:{for(var c=a.length,d="string"==typeof a?a.split(""):a,e=0;e<c;e++)if(e in d&&b.call(void 0,d[e],e,a)){b=e;break a}b=-1}return 0>b?null:"string"==typeof a?a.charAt(b):a[b]};function k(a,b,c){c=null!=c?"="+encodeURIComponent(String(c)):"";if(b+=c){c=a.indexOf("#");0>c&&(c=a.length);var d=a.indexOf("?");if(0>d||d>c){d=c;var e=""}else e=a.substring(d+1,c);a=[a.substr(0,d),e,a.substr(c)];c=a[1];a[1]=b?c?c+"&"+b:b:c;a=a[0]+(a[1]?"?"+a[1]:"")+a[2]}return a};var l=0;function m(a,b){var c=document.createElement("script");c.src=a;c.onload=function(){b&&b(void 0)};c.onerror=function(){b&&b("error")};a=document.getElementsByTagName("head");var d;a&&0!==a.length?d=a[0]:d=document.documentElement;d.appendChild(c)}function n(a){var b=void 0===b?document.cookie:b;return(b=h(b.split("; "),function(c){return-1!=c.indexOf(a+"=")}))?b.split("=")[1]:""}function p(a){return"string"==typeof a&&0<a.length}
		function r(a,b,c){b=void 0===b?"":b;c=void 0===c?".":c;var d=[];Object.keys(a).forEach(function(e){var f=a[e],q=typeof f;"object"==q&&null!=f||"function"==q?d.push(r(f,b+e+c)):null!==f&&void 0!==f&&(e=encodeURIComponent(b+e),d.push(e+"="+encodeURIComponent(f)))});return d.filter(p).join("&")}function t(a,b){a||((window.__ATA||{}).config=b.c,m(b.url))}var u=Math.floor(1E13*Math.random()),v=window.__ATA||{};window.__ATA=v;window.__ATA.cmd=v.cmd||[];v.rid=u;v.createdAt=g();var w=window.__ATA||{},x="s.pubmine.com";
		w&&w.serverDomain&&(x=w.serverDomain);var y="//"+x+"/conf",z=window.top===window,A=window.__ATA_PP&&window.__ATA_PP.gdpr_applies,B="boolean"===typeof A?Number(A):null,C=window.__ATA_PP||null,D=z?document.referrer?document.referrer:null:null,E=z?window.location.href:document.referrer?document.referrer:null,F,G=n("__ATA_tuuid");F=G?G:null;var H=window.innerWidth+"x"+window.innerHeight,I=n("usprivacy"),J=r({gdpr:B,pp:C,rid:u,src:D,ref:E,tuuid:F,vp:H,us_privacy:I?I:null},"",".");
		(function(a){var b=void 0===b?"cb":b;l++;var c="callback__"+g().toString(36)+"_"+l.toString(36);a=k(a,b,c);window[c]=function(d){t(void 0,d)};m(a,function(d){d&&t(d)})})(y+"?"+J);}).call(this);
		</script><link rel="amphtml" href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/amp/"><style type="text/css" id="custom-colors-css">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</style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_gat._anonymizeIp']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-6138 single-format-standard customizer-styles-applied has-sidebar has-header-image widgets-hidden highlander-enabled highlander-light">
<div id="page" class="hfeed site">
		<div id="widgets-wrapper" class="hide">
		
<div id="secondary" class="wrap top-widget-area" role="complementary">
		<div id="sidebar-1" class="widget-area" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://chuttenblog.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/" aria-current="page">This Week in Glean: How Long Must I Wait Before I Can See My&nbsp;Data?</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/11/08/adventures-in-water-softening/">Adventures in Water&nbsp;Softening</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/10/22/this-week-in-glean-the-three-roles-of-data-engagements/">This Week in Glean: The Three Roles of Data&nbsp;Engagements</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/10/19/six-year-moziversary/">Six-Year Moziversary</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/">This Week in Glean: Data Reviews are Important, Glean Parser makes them&nbsp;Easy</a>
									</li>
					</ul>

		</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>
			<ul>
					<li><a href='https://chuttenblog.wordpress.com/2021/12/'>December 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/11/'>November 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/10/'>October 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/09/'>September 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/08/'>August 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/07/'>July 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/04/'>April 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/01/'>January 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/11/'>November 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/10/'>October 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/06/'>June 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/04/'>April 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/03/'>March 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/02/'>February 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/11/'>November 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/10/'>October 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/08/'>August 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/06/'>June 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/05/'>May 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/04/'>April 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/03/'>March 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/01/'>January 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/12/'>December 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/11/'>November 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/10/'>October 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/09/'>September 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/08/'>August 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/07/'>July 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/06/'>June 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/05/'>May 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/04/'>April 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/03/'>March 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/02/'>February 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/01/'>January 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/12/'>December 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/09/'>September 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/08/'>August 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/07/'>July 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/12/'>December 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/11/'>November 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/08/'>August 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/07/'>July 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/05/'>May 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/04/'>April 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/03/'>March 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/12/'>December 2015</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/11/'>November 2015</a></li>
			</ul>

			</aside>	</div><!-- #first .widget-area -->
	
		<div id="sidebar-2" class="widget-area" role="complementary">
		<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">Pages</h1>
			<ul>
				<li class="page_item page-item-1"><a href="https://chuttenblog.wordpress.com/about/">About Me</a></li>
			</ul>

			</aside><aside id="categories-5" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-217843"><a href="https://chuttenblog.wordpress.com/category/legislative/">legislative</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://chuttenblog.wordpress.com/category/mozilla/">mozilla</a>
</li>
	<li class="cat-item cat-item-2007"><a href="https://chuttenblog.wordpress.com/category/musings/">musings</a>
</li>
	<li class="cat-item cat-item-418349615"><a href="https://chuttenblog.wordpress.com/category/phonebg/" title="Backgrounds I set on my phone">phonebg</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://chuttenblog.wordpress.com/category/uncategorized/">Uncategorized</a>
</li>
			</ul>

			</aside><aside id="rss_links-3" class="widget widget_rss_links"><h1 class="widget-title">RSS</h1><ul><li><a href="https://chuttenblog.wordpress.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://chuttenblog.wordpress.com/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</aside>	</div><!-- #second .widget-area -->
	
	
	</div><!-- #secondary -->
	</div>
	
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
					<a class="site-logo"  href="https://chuttenblog.wordpress.com/" title="chuttenblog" rel="home">
				<img src="https://secure.gravatar.com/avatar/5043f3d055047e33f78e537ded657aca/?s=80&#038;d=identicon" width="80" height="80" alt="" class="no-grav header-image" />
			</a>
		
		<div class="site-branding">
			<h1 class="site-title"><a href="https://chuttenblog.wordpress.com/" rel="home">chuttenblog</a></h1>
			<h2 class="site-description"></h2>
		</div>

		
		
				<div class="toggle-wrapper">
			<a href="#" class="widgets-toggle toggle-button" title="Widgets">
				<span class="screen-reader-text">Widgets</span>
			</a>
		</div>
		
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-6138" class="post-6138 post type-post status-publish format-standard hentry category-mozilla tag-data tag-data-science tag-firefox tag-for-a-while-there-i-was-designing-a-system-that-would-use-remote-debugging-via-devtools-to-instrument-running-firefoxen-in-the-wild-but-some-magic-just-isnt-meant-for-us tag-mozilla tag-telemetry tag-this-week-in-glean tag-twig">
	<div class="entry-wrapper">

		
		<header class="entry-header">
					<span class="entry-format theme-genericon"></span>
	
			<div class="entry-meta">
				<span class="posted-on">Posted on <a href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-14T17:01:14-05:00">2021-12-14</time></a></span><span class="categories"> in <a href="https://chuttenblog.wordpress.com/category/mozilla/" rel="category tag">mozilla</a></span>			</div><!-- .entry-meta -->

							<h1 class="entry-title">This Week in Glean: How Long Must I Wait Before I Can See My&nbsp;Data?</h1>					</header><!-- .entry-header -->

		<div class="entry-content">
			
<p>(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean. All “This Week in Glean” blog posts are listed in the <a href="https://mozilla.github.io/glean/book/appendix/twig.html">TWiG index</a>).</p>



<p>You’ve heard about this cool <a href="https://firefox-source-docs.mozilla.org/toolkit/components/glean/index.html">Firefox on Glean</a> thing and wish to instrument a part of Firefox Desktop. So you add a metrics.yaml definition for a new Glean metric, commit a piece of instrumentation to mozilla-central, and then Lando lands it for you.</p>



<p>When can you expect the data collected when users&#8217; Firefoxes trigger that instrumentation to show up in a queryable place like BigQuery?</p>



<p>The answer is one of the more common phrases I say when it comes to data: Well, it depends.</p>



<p>In the broadest sense, we&#8217;re looking at two days:</p>



<p>1) A new Nightly build will be generated within 12h of your commit.</p>



<p>2) Users will pick up the new Nightly build fairly quickly after that, and start triggering the instrumentation.</p>



<p>3) The following 4am a &#8220;metrics&#8221; ping containing data from your instrumentation will be submitted (or some time later if Firefox isn&#8217;t running at 4am)</p>



<p>4) A new schema generated to include your new metric definition will have been <a href="https://protosaur.dev/mps-deploys/">deployed </a>overnight</p>



<p>5) The following 12am UTC a new partition of our user-facing stable views will have the previous day&#8217;s submissions available.</p>



<p>And then you <a href="https://docs.telemetry.mozilla.org/cookbooks/accessing_glean_data.html">commence querying</a>! Easy as that.</p>



<p>Any questions?</p>



<h2 id="the-questions">The Questions:</h2>



<h3 id="what-if-i-added-a-new-metrics-yaml-file">What if I added a new metrics.yaml file?</h3>



<p>That file needs to land in <a href="https://github.com/mozilla/gecko-dev">gecko-dev</a> (the github mirror of mozilla-central) first. Only then can we (and by “we” I here mean the Data Team, by means of <a href="https://firefox-source-docs.mozilla.org/toolkit/components/glean/user/new_definitions_file.html#where-do-i-define-new-metrics-and-pings">a bug you file</a>) <a href="https://github.com/mozilla/probe-scraper/blob/main/repositories.yaml">update the data pipeline</a>. Then you get to wait until the next weekday&#8217;s midnight UTC (ish) for a <a href="https://protosaur.dev/mps-deploys/">schema deploy</a> as per Step 4.</p>



<p>Generally this doesn&#8217;t add too much delay, but if landing the file happens after the pipeline folks have gone home, we get to wait until the next weekday&#8217;s midnight UTC.</p>



<h3 id="the-nightly-population-is-small-and-weird-how-long-until-we-get-data-from-release">The Nightly population is small and weird. How long until we get data from release?</h3>



<p>Uptake of code to release takes a while longer. Code lands in mozilla-central, and gets into the next Nightly within 12h. Getting to Beta from Nightly means waiting until the next merge day (these days that’s on the first Monday of the month, or thereabouts). Getting to Release from Beta means waiting until the merge day after that.</p>



<p>If you&#8217;re unlucky, you&#8217;ll be waiting over two months for your instrumentation to be in a Release build that users can pull down.</p>



<p>And then you get to<a href="https://chuttenblog.wordpress.com/2018/07/06/when-do-all-firefox-users-update/"> wait for enough Release users to update that you&#8217;re getting a representative sample</a>. (This could take a week or so.)</p>



<p>So&#8230; nine weeks?</p>



<h3 id="that-sounds-really-bad-is-there-anything-we-can-do">That sounds really bad! Is there anything we can do?</h3>



<p>Why yes.</p>



<p>The first thing we can do is adjust our expectations. There&#8217;s a four-week sway from the worst-case to best-case on this slow path. It isn&#8217;t likely that you&#8217;ll always be landing instrumentation immediately after a merge day and get to wait the whole month until Nightly merges to Beta.</p>



<p>Your average wait for that is only two weeks. And the best case is a matter of a day or two.</p>



<p>So cross your fingers, and hope your luck is with you.</p>



<p>Secondly, instrumentation is (by itself) very low-risk, so you can <a href="https://release.mozilla.org/tooling/bugzilla/2018/10/03/uplift-form">&#8220;uplift&#8221;</a> the instrumentation change directly to Beta without waiting for merge day.</p>



<p>This can cut your route to release down to _two weeks_, by (e.g.) landing in Nightly on Monday Nov 22, verifying that it works on Tuesday, requesting uplift on Wednesday, getting uplifted in the last Beta on Thursday Nov 25, then making the merge from Beta to Release on Dec 6.</p>



<p>(You do still get to wait a third week for the release population to update to the latest version.)</p>



<p>Thirdly, what are the chances that your instrumentation is measuring a feature you just built or just turned on? You want that feature to benefit from the slow-roll exposure to the more tolerant audiences of Nightly and Beta before it reaches Release, right? Automated testing is great, but nothing can simulate the wild variety of use cases and hardware combinations your feature will experience in the Real World.</p>



<p>So what point is there getting your instrumentation into Release before the feature under instrumentation reaches it? Instead of measuring the interval between landing instrumentation and beginning analysis, perhaps measure the interval between the release of the feature you wish to instrument and beginning analysis?</p>



<p>That interval is only a day: gotta wait for that partition in the stable view. Sounds much better, doesn’t it?</p>



<h3 id="still-can-i-get-data-any-faster">Still, can I get data any faster?</h3>



<p>The fastest time from Point A) Landing a metric, to Point B) Performing preliminary analysis on a metric, is about 12h:</p>



<p>1) Land your code just before a new Nightly is cut.</p>



<p>2) Hope that the number of Nightly users that update to the latest build over the next twelve hours is enough for your purposes.</p>



<p>If you didn&#8217;t luck out and have a schema deploy, you&#8217;ll need to dig your data out of the <a href="https://docs.telemetry.mozilla.org/cookbooks/additional_props.html#additional-properties"><code>additional_properties</code> JSON column</a>. If you are lucky, you can use the friendly columns instead.</p>



<p>To get to the data before the nightly copy-deduplicate to stable views, you&#8217;ll be querying the <a href="https://docs.telemetry.mozilla.org/cookbooks/bigquery/querying.html#table-layout-and-naming">live tables instead</a>. You need to fully-qualify that table name. You need to realize that we haven&#8217;t deduped anything in here. And you need to take narrow slices, because we can&#8217;t cluster the data effectively here, so querying can get expensive, fast.</p>



<h3 id="can-i-get-data-that-quickly-from-release">Can I get data that quickly from release?</h3>



<p>Not yet.</p>



<p>I&#8217;ve seen a proposal internally for dynamically-defined metrics which get pushed to running Firefox instances (talk to :esmyth if you’re interested). Though its present form is proposing the process and possibility, not the technology, there&#8217;s a version of this I can see that would (for a subset of data collection) take the time from &#8220;I wish to instrument this&#8221; to &#8220;I am performing analysis on data received from (a subset of) the release Firefox population&#8221; down to within a business day.</p>



<p>Which is neat! But that speed brings risk, so it&#8217;ll take a while to design a system that doesn&#8217;t expose our users to that risk.</p>



<p>Don&#8217;t expect this for Christmas, is I guess what I mean : )</p>



<p>:chutten</p>
<div id="atatags-370373-61b96260cfb50">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-370373-61b96260cfb50', {
                    sectionId: '370373',
                    format: 'inread'
                });
            });
        </script>
    </div>			<div id="atatags-26942-61b96260cfb84"></div>
			
			<script>
				__ATA.cmd.push(function() {
					__ATA.initDynamicSlot({
						id: 'atatags-26942-61b96260cfb84',
						location: 120,
						formFactor: '001',
						label: {
							text: 'Advertisements',
						},
						creative: {
							reportAd: {
								text: 'Report this ad',
							},
							privacySettings: {
								text: 'Privacy',
								
							}
						}
					});
				});
			</script><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-6138" class="share-twitter sd-button share-icon" href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-6138" class="share-facebook sd-button share-icon" href="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-102555580-6138-61b96260d031c' data-src='//widgets.wp.com/likes/index.html?ver=20211208#blog_id=102555580&amp;post_id=6138&amp;origin=chuttenblog.wordpress.com&amp;obj_id=102555580-6138-61b96260d031c' data-name='like-post-frame-102555580-6138-61b96260d031c' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

			<footer class="entry-footer">
					<span class="tags-links"><a href="https://chuttenblog.wordpress.com/tag/data/" rel="tag">data</a> <a href="https://chuttenblog.wordpress.com/tag/data-science/" rel="tag">data science</a> <a href="https://chuttenblog.wordpress.com/tag/firefox/" rel="tag">firefox</a> <a href="https://chuttenblog.wordpress.com/tag/for-a-while-there-i-was-designing-a-system-that-would-use-remote-debugging-via-devtools-to-instrument-running-firefoxen-in-the-wild-but-some-magic-just-isnt-meant-for-us/" rel="tag">for a while there i was designing a system that would use remote debugging via devtools to instrument running firefoxen in the wild but some magic just isnt meant for us</a> <a href="https://chuttenblog.wordpress.com/tag/mozilla/" rel="tag">mozilla</a> <a href="https://chuttenblog.wordpress.com/tag/telemetry/" rel="tag">telemetry</a> <a href="https://chuttenblog.wordpress.com/tag/this-week-in-glean/" rel="tag">this week in glean</a> <a href="https://chuttenblog.wordpress.com/tag/twig/" rel="tag">twig</a></span>		
			</footer><!-- .entry-footer -->
		</div><!-- .entry-wrapper -->
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://chuttenblog.wordpress.com/2021/11/08/adventures-in-water-softening/" rel="prev">Adventures in Water&nbsp;Softening</a></div></div>
	</nav>
			
		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer wrap" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_website" rel="nofollow">Create a free website or blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202150y' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	</div>
		<!-- CCPA [start] -->
		<script type="text/javascript">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</script>

		<!-- CCPA [end] -->
		<div class="widget widget_eu_cookie_law_widget">
<div
	class="hide-on-button ads-active"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />

		Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
				<a href="https://automattic.com/cookies/" rel="nofollow">
			Cookie Policy		</a>
 </form>
</div>
</div>			<script type="text/javascript">
			( function( $ ) {
				$( document.body ).on( 'post-load', function () {
					if ( typeof __ATA.insertInlineAds === 'function' ) {
						__ATA.insertInlineAds();
					}
				} );
			} )( jQuery );
			</script><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>	<div id="actionbar" style="display: none;"
			class="actnbr-pub-hew actnbr-has-follow">
		<ul>
								<li class="actnbr-btn actnbr-hidden">
								<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
							<div class="actnbr-popover tip tip-top-left actnbr-notice" id="follow-bubble">
							<div class="tip-arrow"></div>
							<div class="tip-inner actnbr-follow-bubble">
															<ul>
											<li class="actnbr-sitename">
			<a href="https://chuttenblog.wordpress.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				chuttenblog			</a>
		</li>
										<form method="post" action="https://subscribe.wordpress.com" accept-charset="utf-8" style="display: none;">
																						<div class="actnbr-follow-count">Join 35 other followers</div>
																					<div>
										<input type="email" name="email" placeholder="Enter your email address" class="actnbr-email-field" aria-label="Enter your email address" />
										</div>
										<input type="hidden" name="action" value="subscribe" />
										<input type="hidden" name="blog_id" value="102555580" />
										<input type="hidden" name="source" value="https://chuttenblog.wordpress.com/2021/12/14/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data/" />
										<input type="hidden" name="sub-type" value="actionbar-follow" />
										<input type="hidden" id="_wpnonce" name="_wpnonce" value="1e65c6019c" />										<div class="actnbr-button-wrap">
											<button type="submit" value="Sign me up">
												Sign me up											</button>
										</div>
									</form>
									<li class="actnbr-login-nudge">
										<div>
											Already have a WordPress.com account? <a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F12%2F14%2Fthis-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data%2F&#038;signup_flow=account">Log in now.</a>										</div>
									</li>
								</ul>
															</div>
						</div>
					</li>
							<li class="actnbr-ellipsis actnbr-hidden">
				<svg class="gridicon gridicons-ellipsis" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M7 12c0 1.104-.896 2-2 2s-2-.896-2-2 .896-2 2-2 2 .896 2 2zm12-2c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2zm-7 0c-1.104 0-2 .896-2 2s.896 2 2 2 2-.896 2-2-.896-2-2-2z"/></g></svg>				<div class="actnbr-popover tip tip-top-left actnbr-more">
					<div class="tip-arrow"></div>
					<div class="tip-inner">
						<ul>
									<li class="actnbr-sitename">
			<a href="https://chuttenblog.wordpress.com">
				<img alt='' src='https://s2.wp.com/i/logo/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' />				chuttenblog			</a>
		</li>
								<li class="actnbr-folded-customize">
								<a href="https://chuttenblog.wordpress.com/wp-admin/customize.php?url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F12%2F14%2Fthis-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data%2F">
									<svg class="gridicon gridicons-customize" height="20" width="20" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M2 6c0-1.505.78-3.08 2-4 0 .845.69 2 2 2 1.657 0 3 1.343 3 3 0 .386-.08.752-.212 1.09.74.594 1.476 1.19 2.19 1.81L8.9 11.98c-.62-.716-1.214-1.454-1.807-2.192C6.753 9.92 6.387 10 6 10c-2.21 0-4-1.79-4-4zm12.152 6.848l1.34-1.34c.607.304 1.283.492 2.008.492 2.485 0 4.5-2.015 4.5-4.5 0-.725-.188-1.4-.493-2.007L18 9l-2-2 3.507-3.507C18.9 3.188 18.225 3 17.5 3 15.015 3 13 5.015 13 7.5c0 .725.188 1.4.493 2.007L3 20l2 2 6.848-6.848c1.885 1.928 3.874 3.753 5.977 5.45l1.425 1.148 1.5-1.5-1.15-1.425c-1.695-2.103-3.52-4.092-5.448-5.977z"/></g></svg>									<span>Customize</span>
								</a>
							</li>
																<li class="actnbr-folded-follow">
												<a class="actnbr-action actnbr-actn-follow " href="">
			<svg class="gridicon gridicons-reader-follow" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 16v2h-3v3h-2v-3h-3v-2h3v-3h2v3h3zM20 2v9h-4v3h-3v4H4c-1.1 0-2-.9-2-2V2h18zM8 13v-1H4v1h4zm3-3H4v1h7v-1zm0-2H4v1h7V8zm7-4H4v2h14V4z"/></g></svg><span>Follow</span>
		</a>
		<a class="actnbr-action actnbr-actn-following  no-display" href="">
			<svg class="gridicon gridicons-reader-following" height="24" width="24" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><g><path d="M23 13.482L15.508 21 12 17.4l1.412-1.388 2.106 2.188 6.094-6.094L23 13.482zm-7.455 1.862L20 10.89V2H2v14c0 1.1.9 2 2 2h4.538l4.913-4.832 2.095 2.176zM8 13H4v-1h4v1zm3-2H4v-1h7v1zm0-2H4V8h7v1zm7-3H4V4h14v2z"/></g></svg><span>Following</span>
		</a>
										</li>
																	<li class="actnbr-signup"><a href="https://wordpress.com/start/">Sign up</a></li>
									<li class="actnbr-login"><a href="https://wordpress.com/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F12%2F14%2Fthis-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data%2F&#038;signup_flow=account">Log in</a></li>
																	<li class="actnbr-shortlink"><a href="https://wp.me/p6Wjog-1B0">Copy shortlink</a></li>
																	<li class="flb-report"><a href="http://en.wordpress.com/abuse/">Report this content</a></li>
																	<li class="actnbr-reader">
										<a href="https://wordpress.com/read/blogs/102555580/posts/6138">
											View post in Reader										</a>
									</li>
																	<li class="actnbr-subs">
										<a href="https://subscribe.wordpress.com/">Manage subscriptions</a>
									</li>
																		<li class="actnbr-fold"><a href="">Collapse this bar</a></li>
															</ul>
					</div>
				</div>
			</li>
		</ul>
	</div>
	
<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210915";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20211028";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

	
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chuttenblog.wordpress.com\/2021\/12\/14\/this-week-in-glean-how-long-must-i-wait-before-i-can-see-my-data\/":6138};
	</script>
				<script id='comment-like-js-extra'>
var comment_like_text = {"loading":"Loading...","swipeUrl":"https:\/\/s2.wp.com\/wp-content\/mu-plugins\/comment-likes\/js\/lib\/swipe.js?ver=20131008"};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s2.wp.com/_static/??-eJyFkNFuwzAIRX9oLlo3VevDtG8hNklIbOwZ3Ozz56naNOUhfQIu54IAtuJ8FiMxWBQC3dhT+Tot+gT/Wqm5EtvEohB5JYXPRo1mlBCpHsA+p9QldzctO2FvtJlSx0obYKbtB+/hMSR44wmNszxmdeXSl8vqxuybupGPbt04TGQK1Ho3r0wu4gZGqUQ02ukHczAkFjdghYRqVHvmrKJf/17A4mML9x/1ktJA4dRNB0NLVnNjRK6gM1aW6Td200d6f768vJ2v5+vldfkGchS0aQ=='></script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20211208#ver=20211208&amp;origin=https://chuttenblog.wordpress.com' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>

		<script src="//stats.wp.com/w.js?63" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'102555580','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'102555580','v':'wpcom','tz':'-5','user_id':'0','post':'6138','subd':'chuttenblog'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9CSi1tXWVrbHluQismUnV8UV1kWzR+UDkzdC9EVGRRfHMrK1lJLUtLMF9SQ3xGeGlwbzAvfFhkNXk9MSxUcTEwfDYyZzRPfnRteUdhcltCVzM1SjEuOG85LG15d2hYeWNuWVUrPXZMOEgxRmFlaFBuJm94dzYldH58OHwlb1N2RWlJM3NEeFdnWC5sNEFJOHBzUzNTR2xYYndXLFpBRD8vP1BxLjVuWmxNJm9LWlJrXzM3aHFadVgvaXMxTkUuSFdQWGJILmpIRiVRVmsmNC4zQVpL'}]);
_stq.push([ 'clickTrackerInit', '102555580', '6138' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script defer id="bilmur" data-customproperties="{&quot;enq_jquery&quot;:&quot;1&quot;,&quot;logged_in&quot;:&quot;0&quot;}" data-provider="wordpress.com" data-service="simple" src="/wp-content/js/bilmur.min.js?i=2&m=202150"></script><script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
