<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://chuttenblog.wordpress.com/xmlrpc.php">

<title>This Week in Glean: Data Reviews are Important, Glean Parser makes them Easy &#8211; chuttenblog</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel='dns-prefetch' href='//a.teads.tv' />
<link rel='dns-prefetch' href='//prebid.media.net' />
<link rel='dns-prefetch' href='//adserver-us.adtech.advertising.com' />
<link rel='dns-prefetch' href='//fastlane.rubiconproject.com' />
<link rel='dns-prefetch' href='//prebid-server.rubiconproject.com' />
<link rel='dns-prefetch' href='//hb-api.omnitagjs.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//apex.go.sonobi.com' />
<link rel='dns-prefetch' href='//u.openx.net' />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Feed" href="https://chuttenblog.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Comments Feed" href="https://chuttenblog.wordpress.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1625065786h&ver=5.8.1-alpha-51081"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNkttOwzAMhl+I1OsGiBvEs+RgBW85KU5W9e1JO6haCoybKLb/z6cEhiR0DAVDAeWiFclVS4FhiNlIw2BdVNJ1mvkBVlpfF6WjCzKcsSSpL2K2dvIvra3NVJhti2SEa993j10PqpIzU/05gcoyj8BldLgkoqBdNVMdBo+GJDr0cyMrIzk5YhYOrdRj5yncx1tsbW+g35ufO13NLMdYi7CZzLe2/50iy0LB8h1cx0/s2PWHtjdDXBan+JldvdS08+b3Se4H/wMbUmOEUikjs2inp+pFeW/g/qU35fyU+vYloAm3nhtKEGKhRvNymQJv/rV/Ph2e+pfj8XT+ALyw/gw=?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='hew-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C600italic%2C700italic%7CNoto+Serif%3A400%2C700%2C400italic%2C700italic&#038;subset=latin' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyFj0sOwjAMRC9EMEUqKgvEWUIwqcGJo8ZRxO0JYtOK325G88YfqMk4iYpRIRSTuHiKGTxGnKgFX+Ta5byCWVdHDJghlROMWCHrnfEfRNG9QFOTk/CGz+6pdPaoGbC0VG6Ehm0FxZDYahv5ed/iITEszipJXBhzYUvTr+qEJxbfpIdGzeyzdAyHrt9vul2/HYbrAxlzfR0=?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='all-css-6-1' href='https://s1.wp.com/_static/??-eJxti0EKgCAQAD+ULUaJl+gtJqbG6opr9P3o0CHqNAzMwFmEpdxcbpAOUfDwMTMU4iY2NLECB1Nj9g97y9zB/8Vko0GB5Oktn6kFlxxDGMEjrQbvYEmzVHIclNZy2i9lFDfR?cssminify=yes' type='text/css' media='all' />
<script id='wpcom-actionbar-placeholder-js-extra'>
var actionbardata = {"siteID":"102555580","siteName":"chuttenblog","siteURL":"http:\/\/chuttenblog.wordpress.com","siteHost":"chuttenblog.wordpress.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/hew","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F09%2F07%2Fthis-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy%2F&signup_flow=account","themeURL":"https:\/\/wordpress.com\/theme\/hew\/","xhrURL":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"f6dae9c666","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"9a75ca3883\" \/>","referer":"https:\/\/chuttenblog.wordpress.com\/2021\/09\/07\/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy\/","canFollow":"1","feedID":"40067007","statusMessage":"","customizeLink":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F09%2F07%2Fthis-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy%2F","postID":"6090","shortlink":"https:\/\/wp.me\/p6Wjog-1Ae","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/chuttenblog.wordpress.com\/6090","statsLink":"https:\/\/wordpress.com\/stats\/post\/6090\/chuttenblog.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Hew","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 34 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F09%2F07%2Fthis-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy%2F&signup_flow=account\">Log in now.<\/a>","stats":"Stats","notifyNewPosts":"Notify me of new posts","notifyNewPostsDetails":"Receive web and mobile notifications for new posts from this site.","emailNewPosts":"Email me new posts","emailNewPostsDetails":"You can customize your notification settings further <a href=\"https:\/\/wordpress.com\/following\/manage?s=chuttenblog.wordpress.com\">here<\/a>.","emailNewComments":"Email me new comments"}};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJyFzUEKwkAMheELmQ4qtboQz9LWWGaYJGOSQXt7KyjUlau3+D944VFgFHZkD8lCEXNCs37CJtkm/FaSIWaEaqgLYIfIN/m6yGOuV7Q3TPeKOn+moch/EVCctHdc49WzZoei8pyXdqHz9rDrTse2a/fpBYU+RvU='></script>
<script type='text/javascript'>
	window.addEventListener( 'DOMContentLoaded', function() {
		rltInitialize( {"token":null,"iframeOrigins":["https:\/\/widgets.wp.com"]} );
	} );
</script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chuttenblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/" />
<link rel='shortlink' href='https://wp.me/p6Wjog-1Ae' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F09%2F07%2Fthis-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2021%2F09%2F07%2Fthis-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="This Week in Glean: Data Reviews are Important, Glean Parser makes them Easy" />
<meta property="og:url" content="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/" />
<meta property="og:description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or wh…" />
<meta property="article:published_time" content="2021-09-07T15:26:50+00:00" />
<meta property="article:modified_time" content="2021-09-07T15:26:50+00:00" />
<meta property="og:site_name" content="chuttenblog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="This Week in Glean: Data Reviews are Important, Glean Parser makes them&nbsp;Easy" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://chuttenblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://chuttenblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://chuttenblog.wordpress.com/osd.xml" title="chuttenblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="chuttenblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://chuttenblog.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean.) All “This Week in Glean” blog posts are listed in the&hellip;" />
		<script type="text/javascript">

			window.doNotSellCallback = function() {

				var linkElements = [
					'a[href="https://wordpress.com/?ref=footer_blog"]',
					'a[href="https://wordpress.com/?ref=footer_website"]',
					'a[href="https://wordpress.com/?ref=vertical_footer"]',
					'a[href^="https://wordpress.com/?ref=footer_segment_"]',
				].join(',');

				var dnsLink = document.createElement( 'a' );
				dnsLink.href = 'https://wordpress.com/advertising-program-optout/';
				dnsLink.classList.add( 'do-not-sell-link' );
				dnsLink.rel = 'nofollow';
				dnsLink.style.marginLeft = '0.5em';
				dnsLink.textContent = 'Do Not Sell My Personal Information';

				var creditLinks = document.querySelectorAll( linkElements );

				if ( 0 === creditLinks.length ) {
					return false;
				}

				Array.prototype.forEach.call( creditLinks, function( el ) {
					el.insertAdjacentElement( 'afterend', dnsLink );
				});

				return true;
			};

		</script>
				<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { 'pt': 1, 'ht': 0, 'tn': 'hew', 'amp': false, 'consent': __ATA_CC(), 'gdpr_applies': false, 'ad': { 'label': { 'text': 'Advertisements' }, 'reportAd': { 'text': 'Report this ad' } }, 'siteid': 8982, 'blogid': 102555580 };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript">
		(function(){var g=Date.now||function(){return+new Date};function h(a,b){a:{for(var c=a.length,d="string"==typeof a?a.split(""):a,e=0;e<c;e++)if(e in d&&b.call(void 0,d[e],e,a)){b=e;break a}b=-1}return 0>b?null:"string"==typeof a?a.charAt(b):a[b]};function k(a,b,c){c=null!=c?"="+encodeURIComponent(String(c)):"";if(b+=c){c=a.indexOf("#");0>c&&(c=a.length);var d=a.indexOf("?");if(0>d||d>c){d=c;var e=""}else e=a.substring(d+1,c);a=[a.substr(0,d),e,a.substr(c)];c=a[1];a[1]=b?c?c+"&"+b:b:c;a=a[0]+(a[1]?"?"+a[1]:"")+a[2]}return a};var l=0;function m(a,b){var c=document.createElement("script");c.src=a;c.onload=function(){b&&b(void 0)};c.onerror=function(){b&&b("error")};a=document.getElementsByTagName("head");var d;a&&0!==a.length?d=a[0]:d=document.documentElement;d.appendChild(c)}function n(a){var b=void 0===b?document.cookie:b;return(b=h(b.split("; "),function(c){return-1!=c.indexOf(a+"=")}))?b.split("=")[1]:""}function p(a){return"string"==typeof a&&0<a.length}
		function r(a,b,c){b=void 0===b?"":b;c=void 0===c?".":c;var d=[];Object.keys(a).forEach(function(e){var f=a[e],q=typeof f;"object"==q&&null!=f||"function"==q?d.push(r(f,b+e+c)):null!==f&&void 0!==f&&(e=encodeURIComponent(b+e),d.push(e+"="+encodeURIComponent(f)))});return d.filter(p).join("&")}function t(a,b){a||((window.__ATA||{}).config=b.c,m(b.url))}var u=Math.floor(1E13*Math.random()),v=window.__ATA||{};window.__ATA=v;window.__ATA.cmd=v.cmd||[];v.rid=u;v.createdAt=g();var w=window.__ATA||{},x="s.pubmine.com";
		w&&w.serverDomain&&(x=w.serverDomain);var y="//"+x+"/conf",z=window.top===window,A=window.__ATA_PP&&window.__ATA_PP.gdpr_applies,B="boolean"===typeof A?Number(A):null,C=window.__ATA_PP||null,D=z?document.referrer?document.referrer:null:null,E=z?window.location.href:document.referrer?document.referrer:null,F,G=n("__ATA_tuuid");F=G?G:null;var H=window.innerWidth+"x"+window.innerHeight,I=n("usprivacy"),J=r({gdpr:B,pp:C,rid:u,src:D,ref:E,tuuid:F,vp:H,us_privacy:I?I:null},"",".");
		(function(a){var b=void 0===b?"cb":b;l++;var c="callback__"+g().toString(36)+"_"+l.toString(36);a=k(a,b,c);window[c]=function(d){t(void 0,d)};m(a,function(d){d&&t(d)})})(y+"?"+J);}).call(this);
		</script><link rel="amphtml" href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/amp/"><style type="text/css" id="custom-colors-css">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</style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_gat._anonymizeIp']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-6090 single-format-standard customizer-styles-applied has-sidebar has-header-image widgets-hidden highlander-enabled highlander-light">
<div id="page" class="hfeed site">
		<div id="widgets-wrapper" class="hide">
		
<div id="secondary" class="wrap top-widget-area" role="complementary">
		<div id="sidebar-1" class="widget-area" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://chuttenblog.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/" aria-current="page">This Week in Glean: Data Reviews are Important, Glean Parser makes them&nbsp;Easy</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/08/20/i-assembled-a-home-audio-thingy/">I Assembled A Home Audio&nbsp;Thingy</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/07/22/this-week-in-glean-firefox-telemetry-is-to-glean-as-c-is-to-rust/">This Week in Glean: Firefox Telemetry is to Glean as C++ is to&nbsp;Rust</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/07/06/responsible-data-collection-is-good-actually-ubisoft-data-summit-2021/">Responsible Data Collection is Good, Actually (Ubisoft Data Summit&nbsp;2021)</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2021/04/26/data-science-is-interesting-why-are-there-so-many-canadians-in-india/">Data Science is Interesting: Why are there so many Canadians in&nbsp;India?</a>
									</li>
					</ul>

		</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>
			<ul>
					<li><a href='https://chuttenblog.wordpress.com/2021/09/'>September 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/08/'>August 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/07/'>July 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/04/'>April 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2021/01/'>January 2021</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/11/'>November 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/10/'>October 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/06/'>June 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/04/'>April 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/03/'>March 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/02/'>February 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/11/'>November 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/10/'>October 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/08/'>August 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/06/'>June 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/05/'>May 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/04/'>April 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/03/'>March 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/01/'>January 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/12/'>December 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/11/'>November 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/10/'>October 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/09/'>September 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/08/'>August 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/07/'>July 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/06/'>June 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/05/'>May 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/04/'>April 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/03/'>March 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/02/'>February 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/01/'>January 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/12/'>December 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/09/'>September 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/08/'>August 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/07/'>July 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/12/'>December 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/11/'>November 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/08/'>August 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/07/'>July 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/05/'>May 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/04/'>April 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/03/'>March 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/12/'>December 2015</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/11/'>November 2015</a></li>
			</ul>

			</aside>	</div><!-- #first .widget-area -->
	
		<div id="sidebar-2" class="widget-area" role="complementary">
		<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">Pages</h1>
			<ul>
				<li class="page_item page-item-1"><a href="https://chuttenblog.wordpress.com/about/">About Me</a></li>
			</ul>

			</aside><aside id="categories-5" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-217843"><a href="https://chuttenblog.wordpress.com/category/legislative/">legislative</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://chuttenblog.wordpress.com/category/mozilla/">mozilla</a>
</li>
	<li class="cat-item cat-item-2007"><a href="https://chuttenblog.wordpress.com/category/musings/">musings</a>
</li>
	<li class="cat-item cat-item-418349615"><a href="https://chuttenblog.wordpress.com/category/phonebg/" title="Backgrounds I set on my phone">phonebg</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://chuttenblog.wordpress.com/category/uncategorized/">Uncategorized</a>
</li>
			</ul>

			</aside><aside id="rss_links-3" class="widget widget_rss_links"><h1 class="widget-title">RSS</h1><ul><li><a href="https://chuttenblog.wordpress.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://chuttenblog.wordpress.com/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</aside>	</div><!-- #second .widget-area -->
	
	
	</div><!-- #secondary -->
	</div>
	
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
					<a class="site-logo"  href="https://chuttenblog.wordpress.com/" title="chuttenblog" rel="home">
				<img src="https://secure.gravatar.com/avatar/5043f3d055047e33f78e537ded657aca/?s=80&#038;d=identicon" width="80" height="80" alt="" class="no-grav header-image" />
			</a>
		
		<div class="site-branding">
			<h1 class="site-title"><a href="https://chuttenblog.wordpress.com/" rel="home">chuttenblog</a></h1>
			<h2 class="site-description"></h2>
		</div>

		
		
				<div class="toggle-wrapper">
			<a href="#" class="widgets-toggle toggle-button" title="Widgets">
				<span class="screen-reader-text">Widgets</span>
			</a>
		</div>
		
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-6090" class="post-6090 post type-post status-publish format-standard hentry category-mozilla tag-data tag-firefox tag-glean tag-mozilla tag-no-i-will-not-teach-a-machine-learning-algorithm-to-fill-in-the-rest-of-the-form-for-you tag-this-week-in-glean tag-twig tag-work">
	<div class="entry-wrapper">

		
		<header class="entry-header">
					<span class="entry-format theme-genericon"></span>
	
			<div class="entry-meta">
				<span class="posted-on">Posted on <a href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/" rel="bookmark"><time class="entry-date published updated" datetime="2021-09-07T11:26:50-04:00">2021-09-07</time></a></span><span class="categories"> in <a href="https://chuttenblog.wordpress.com/category/mozilla/" rel="category tag">mozilla</a></span>			</div><!-- .entry-meta -->

							<h1 class="entry-title">This Week in Glean: Data Reviews are Important, Glean Parser makes them&nbsp;Easy</h1>					</header><!-- .entry-header -->

		<div class="entry-content">
			
<p>(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean.) All “This Week in Glean” blog posts are listed in the <a href="https://mozilla.github.io/glean/book/appendix/twig.html">TWiG index</a>).</p>



<p>At Mozilla we put a lot of stock in Openness. Source? <a href="https://firefox-source-docs.mozilla.org/contributing/contributing_to_mozilla.html">Open</a>. Bug tracker? <a href="https://bugzilla.mozilla.org">Open</a>. Discussion Forums (Fora?)? Open (<a href="https://chat.mozilla.org/">synchronous</a> and <a href="https://discourse.mozilla.org/">asynchronous</a>).</p>



<p>We also have an open process for determining if a new or expanded data collection in a Mozilla project is in line with our <a href="https://www.mozilla.org/privacy/principles/">Privacy Principles</a> and <a href="https://www.mozilla.org/privacy/">Policies</a>: <a href="https://wiki.mozilla.org/Data_Collection">Data Review</a>.</p>



<p>Basically, when a new piece of instrumentation is put up for code review (or before, or after), the instrumentor fills out <a href="https://github.com/mozilla/data-review/blob/main/request.md">a form</a> and asks a volunteer Data Steward to review it. If the instrumentation (as explained in the filled-in form) is obviously in line with our privacy commitments to our users, the Data Steward gives it the go-ahead to ship.</p>



<p>(If it isn’t _obviously_ okay then we kick it up to our Trust Team to make the decision. They sit next to Legal, in case you need to find them.)</p>



<p>The Data Review Process and its forms are very generic. They’re designed to work for any instrumentation (tab count, bytes transferred, theme colour) being added to any project (<a href="https://firefox.com">Firefox Desktop</a>, <a href="https://mozilla.org">mozilla.org</a>, <a href="https://en.wikipedia.org/wiki/Firefox_Focus">Focus</a>) and being collected by any data collection system (<a href="https://firefox-source-docs.mozilla.org/toolkit/components/telemetry">Firefox Telemetry</a>, <a href="https://firefox-source-docs.mozilla.org/toolkit/crashreporter/crashreporter/index.html">Crash Reporter</a>, <a href="https://mozilla.github.io/glean/book/index.html">Glean</a>). This is great for the process as it means we can use it and rely on it anywhere.</p>



<p>It isn’t so great for users _of_ the process. If you only ever write Data Reviews for one system, you’ll find yourself answering the same questions with the same answers every time.</p>



<p>And Glean makes this worse (better?) by including in its metrics definitions almost every piece of information you need in order to answer the review. So now you get to write the answers first in YAML and then in English during Data Review.</p>



<p>But no more! Introducing <code>glean_parser data-review</code> and <code>mach data-review</code>: command-line tools that will generate for you a Data Review Request skeleton with all the easy parts filled in. It works like this:</p>



<ol><li>Write your instrumentation, providing full information in the metrics definition.</li><li>Call <code>python -m glean_parser data-review &lt;bug_number&gt; &lt;list of metrics.yaml files&gt;</code> (or <code>mach data-review &lt;bug_number&gt;</code> if you’re adding the instrumentation to Firefox Desktop).</li><li><a href="https://github.com/mozilla/glean_parser/">glean_parser</a> will parse the metrics definitions files, pull out only the definitions that were added or changed in &lt;bug_number&gt;, and then output a partially-filled-out form for you.</li></ol>



<p>Here’s an example. Say I’m working on <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1664461">bug 1664461</a> and add a new piece of instrumentation to Firefox Desktop:</p>



<div class="wp-container-6137b3979b239 wp-block-group"><div class="wp-block-group__inner-container">
<pre class="wp-block-code"><code>fog.ipc:
  replay_failures:
    type: counter
    description: |
      The number of times the ipc buffer failed to be replayed in the
      parent process.
    bugs:
      - https://bugzilla.mozilla.org/show_bug.cgi?id=1664461
    data_reviews:
      - https://bugzilla.mozilla.org/show_bug.cgi?id=1664461
    data_sensitivity:
      - technical
    notification_emails:
      - chutten@mozilla.com
      - glean-team@mozilla.com
    expires: never</code></pre>
</div></div>



<p>I’m sure to fill in the `bugs` field correctly (because that’s important on its own _and_ it’s what glean_parser data-review uses to find which data I added), and have categorized the data_sensitivity. I also included a helpful description. (The data_reviews field currently points at the bug I’ll attach the Data Review Request for. I’d better remember to come back before I land this code and update it to point at the specific comment…)</p>



<p>Then I can simply use <code>mach data-review 1664461</code> and it spits out:</p>



<pre class="wp-block-code"><code>!! Reminder: it is your responsibility to complete and check the correctness of
!! this automatically-generated request skeleton before requesting Data
!! Collection Review. See https://wiki.mozilla.org/Data_Collection for details.

DATA REVIEW REQUEST
1. What questions will you answer with this data?

TODO: Fill this in.

2. Why does Mozilla need to answer these questions? Are there benefits for users?
   Do we need this information to address product or business requirements?

TODO: Fill this in.

3. What alternative methods did you consider to answer these questions?
   Why were they not sufficient?

TODO: Fill this in.

4. Can current instrumentation answer these questions?

TODO: Fill this in.

5. List all proposed measurements and indicate the category of data collection for each
   measurement, using the Firefox data collection categories found on the Mozilla wiki.

Measurement Name | Measurement Description | Data Collection Category | Tracking Bug
---------------- | ----------------------- | ------------------------ | ------------
fog_ipc.replay_failures | The number of times the ipc buffer failed to be replayed in the parent process.  | technical | https://bugzilla.mozilla.org/show_bug.cgi?id=1664461


6. Please provide a link to the documentation for this data collection which
   describes the ultimate data set in a public, complete, and accurate way.

This collection is Glean so is documented
&#091;in the Glean Dictionary](https://dictionary.telemetry.mozilla.org).

7. How long will this data be collected?

This collection will be collected permanently.
**TODO: identify at least one individual here** will be responsible for the permanent collections.

8. What populations will you measure?

All channels, countries, and locales. No filters.

9. If this data collection is default on, what is the opt-out mechanism for users?

These collections are Glean. The opt-out can be found in the product's preferences.

10. Please provide a general description of how you will analyze this data.

TODO: Fill this in.

11. Where do you intend to share the results of your analysis?

TODO: Fill this in.

12. Is there a third-party tool (i.e. not Telemetry) that you
    are proposing to use for this data collection?

No.</code></pre>



<p>As you can see, this Data Review Request skeleton comes partially filled out. Everything you previously had to mechanically fill out has been done for you, leaving you more time to focus on only the interesting questions like “Why do we need this?” and “How are you going to use it?”.</p>



<p>Also, this saves you from having to remember the URL to the Data Review Request Form Template each time you need it. We’ve got you covered.</p>



<p>And since this is part of Glean, this means this is already available to <a href="https://dictionary.telemetry.mozilla.org/">every project you can see here</a>. This isn’t just a Firefox Desktop thing.&nbsp;</p>



<p>Hope this saves you some time! If you can think of other time-saving improvements we could add once to Glean so every Mozilla project can take advantage of, please <a href="https://chat.mozilla.org/#/room/#glean:mozilla.org">tell us on Matrix</a>.</p>



<p>If you’re interested in how this is implemented, glean_parser’s part of this is <a href="https://github.com/mozilla/glean_parser/blob/main/glean_parser/data_review.py">over here</a>, while the mach command part is <a href="https://searchfox.org/mozilla-central/source/toolkit/components/glean/build_scripts/mach_commands.py">here</a>.</p>



<p>:chutten</p>
<div id="atatags-370373-6137b3979bb37">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-370373-6137b3979bb37', {
                    sectionId: '370373',
                    format: 'inread'
                });
            });
        </script>
    </div>			<div id="atatags-26942-6137b3979bb8e"></div>
			
			<script>
				__ATA.cmd.push(function() {
					__ATA.initDynamicSlot({
						id: 'atatags-26942-6137b3979bb8e',
						location: 120,
						formFactor: '001',
						label: {
							text: 'Advertisements',
						},
						creative: {
							reportAd: {
								text: 'Report this ad',
							},
							privacySettings: {
								text: 'Privacy',
								
							}
						}
					});
				});
			</script><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-6090" class="share-twitter sd-button share-icon" href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-6090" class="share-facebook sd-button share-icon" href="https://chuttenblog.wordpress.com/2021/09/07/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-102555580-6090-6137b3979c78e' data-src='//widgets.wp.com/likes/index.html?ver=20210818#blog_id=102555580&amp;post_id=6090&amp;origin=chuttenblog.wordpress.com&amp;obj_id=102555580-6090-6137b3979c78e' data-name='like-post-frame-102555580-6090-6137b3979c78e' data-title='Like or Reblog'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

			<footer class="entry-footer">
					<span class="tags-links"><a href="https://chuttenblog.wordpress.com/tag/data/" rel="tag">data</a> <a href="https://chuttenblog.wordpress.com/tag/firefox/" rel="tag">firefox</a> <a href="https://chuttenblog.wordpress.com/tag/glean/" rel="tag">glean</a> <a href="https://chuttenblog.wordpress.com/tag/mozilla/" rel="tag">mozilla</a> <a href="https://chuttenblog.wordpress.com/tag/no-i-will-not-teach-a-machine-learning-algorithm-to-fill-in-the-rest-of-the-form-for-you/" rel="tag">no i will not teach a machine learning algorithm to fill in the rest of the form for you</a> <a href="https://chuttenblog.wordpress.com/tag/this-week-in-glean/" rel="tag">this week in glean</a> <a href="https://chuttenblog.wordpress.com/tag/twig/" rel="tag">twig</a> <a href="https://chuttenblog.wordpress.com/tag/work/" rel="tag">work</a></span>		
			</footer><!-- .entry-footer -->
		</div><!-- .entry-wrapper -->
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://chuttenblog.wordpress.com/2021/08/20/i-assembled-a-home-audio-thingy/" rel="prev">I Assembled A Home Audio&nbsp;Thingy</a></div></div>
	</nav>
			
		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer wrap" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_website" rel="nofollow">Create a free website or blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202136y' id='grofiles-cards-js'></script>
<script id='wpgroho-js-extra'>
var WPGroHo = {"my_hash":""};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1610363240h'></script>

	<script>
		// Initialize and attach hovercards to all gravatars
		( function() {
			function init() {
				if ( typeof Gravatar === 'undefined' ) {
					return;
				}

				if ( typeof Gravatar.init !== 'function' ) {
					return;
				}

				Gravatar.profile_cb = function ( hash, id ) {
					WPGroHo.syncProfileData( hash, id );
				};

				Gravatar.my_hash = WPGroHo.my_hash;
				Gravatar.init( 'body', '#wp-admin-bar-my-account' );
			}

			if ( document.readyState !== 'loading' ) {
				init();
			} else {
				document.addEventListener( 'DOMContentLoaded', init );
			}
		} )();
	</script>

		<div style="display:none">
	</div>
		<!-- CCPA [start] -->
		<script type="text/javascript">
			( function () {

				var setupPrivacy = function() {

					// Minimal Mozilla Cookie library
					// https://developer.mozilla.org/en-US/docs/Web/API/Document/cookie/Simple_document.cookie_framework
					var cookieLib = window.cookieLib = {getItem:function(e){return e&&decodeURIComponent(document.cookie.replace(new RegExp("(?:(?:^|.*;)\\s*"+encodeURIComponent(e).replace(/[\-\.\+\*]/g,"\\$&")+"\\s*\\=\\s*([^;]*).*$)|^.*$"),"$1"))||null},setItem:function(e,o,n,t,r,i){if(!e||/^(?:expires|max\-age|path|domain|secure)$/i.test(e))return!1;var c="";if(n)switch(n.constructor){case Number:c=n===1/0?"; expires=Fri, 31 Dec 9999 23:59:59 GMT":"; max-age="+n;break;case String:c="; expires="+n;break;case Date:c="; expires="+n.toUTCString()}return"rootDomain"!==r&&".rootDomain"!==r||(r=(".rootDomain"===r?".":"")+document.location.hostname.split(".").slice(-2).join(".")),document.cookie=encodeURIComponent(e)+"="+encodeURIComponent(o)+c+(r?"; domain="+r:"")+(t?"; path="+t:"")+(i?"; secure":""),!0}};

					// Implement IAB USP API.
					window.__uspapi = function( command, version, callback ) {

						if ( typeof callback !== 'function' ) {
							return;
						}

						if ( command !== 'getUSPData' || version !== 1 ) {
							callback( null, false );
							return;
						}

						// Check for GPC.
						if ( navigator.globalPrivacyControl ) {
							callback( { version: 1, uspString: '1YYN' }, true );
							return;
						}

						// Check for cookie.
						var consent = cookieLib.getItem( 'usprivacy' );

						if ( null === consent ) {
							callback( null, false );
							return;
						}

						callback( { version: 1, uspString: consent }, true );
					};

					// Initialization.
					document.addEventListener( 'DOMContentLoaded', function() {

						var setDefaultOptInCookie = function() {
							var value = '1YNN';
							var domain = '.wordpress.com' === location.hostname.slice( -14 ) ? '.rootDomain' : location.hostname;
							cookieLib.setItem( 'usprivacy', value, 365 * 24 * 60 * 60, '/', domain );
						};

						var setCcpaAppliesCookie = function( value ) {
							var domain = '.wordpress.com' === location.hostname.slice( -14 ) ? '.rootDomain' : location.hostname;
							cookieLib.setItem( 'ccpa_applies', value, 24 * 60 * 60, '/', domain );
						}

						var maybeCallDoNotSellCallback = function() {
							if ( 'function' === typeof window.doNotSellCallback ) {
								return window.doNotSellCallback();
							}

							return false;
						}

						var usprivacyCookie = cookieLib.getItem( 'usprivacy' );

						if ( null !== usprivacyCookie ) {
							maybeCallDoNotSellCallback();
							return;
						}

						var ccpaCookie = cookieLib.getItem( 'ccpa_applies' );

						if ( null === ccpaCookie ) {

							var request = new XMLHttpRequest();
							request.open( 'GET', 'https://public-api.wordpress.com/geo/', true );

							request.onreadystatechange = function () {
								if ( 4 === this.readyState ) {
									if ( 200 === this.status ) {

										var data = JSON.parse( this.response );
										var ccpa_applies = data['region'] && data['region'].toLowerCase() === 'california';

										setCcpaAppliesCookie( ccpa_applies );

										if ( ccpa_applies ) {
											if ( maybeCallDoNotSellCallback() ) {
												setDefaultOptInCookie();
											}
										}
									} else {
										setCcpaAppliesCookie( true );
										if ( maybeCallDoNotSellCallback() ) {
											setDefaultOptInCookie();
										}
									}
								}
							};

							request.send();
						} else {
							if ( ccpaCookie === 'true' ) {
								if ( maybeCallDoNotSellCallback() ) {
									setDefaultOptInCookie();
								}
							}
						}
					} );
				};

				if ( window.defQueue && defQueue.isLOHP && defQueue.isLOHP === 2020 ) {
					defQueue.items.push( setupPrivacy );
				} else {
					setupPrivacy();
				}

			} )();
		</script>

		<!-- CCPA [end] -->
					<script type="text/javascript">
			( function( $ ) {
				$( document.body ).on( 'post-load', function () {
					if ( typeof __ATA.insertInlineAds === 'function' ) {
						__ATA.insertInlineAds();
					}
				} );
			} )( jQuery );
			</script>
<script>
window.addEventListener( "load", function( event ) {
	var link = document.createElement( "link" );
	link.href = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.css?v=20210901";
	link.type = "text/css";
	link.rel = "stylesheet";
	document.head.appendChild( link );

	var script = document.createElement( "script" );
	script.src = "https://s0.wp.com/wp-content/mu-plugins/actionbar/actionbar.js?v=20210901";
	script.defer = true;
	document.body.appendChild( script );
} );
</script>

	<style>.wp-container-6137b3979b239 .alignleft { float: left; margin-right: 2em; }.wp-container-6137b3979b239 .alignright { float: right; margin-left: 2em; }.wp-container-6137b3979b239 > * + * { margin-top: var( --wp--style--block-gap ); margin-bottom: 0; }</style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chuttenblog.wordpress.com\/2021\/09\/07\/this-week-in-glean-data-reviews-are-important-glean-parser-makes-them-easy\/":6090};
	</script>
				<div class="widget widget_eu_cookie_law_widget">
<div
	class="hide-on-button ads-active"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />

		Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
				<a href="https://automattic.com/cookies/" rel="nofollow">
			Cookie Policy		</a>
 </form>
</div>
</div><script id='comment-like-js-extra'>
var comment_like_text = {"loading":"Loading..."};
</script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script crossorigin='anonymous' type='text/javascript' src='https://s1.wp.com/_static/??-eJyFUe1uwyAMfKERtG6ttB/TnoWAk5jwNQyh3dPPVVdpTaT0l+F8x5mzbEnoGAqEIi1JAwtqSOfO0ot8bNnvCvnyVzoMC0J7SrNQktKzyED4A2u6ryK5OmIg6XAGkiyqMKlgHOQdso7eMyRuIntV95Iapj2HjegBWAvLBJ5pqfZygnalT9vvbklBLTiqgjE859KMic3DLIaoK4kBN7H/G7+hGaGQhMrdOCMIp5os4JNTBVb4zjvKeAyiV1l6RQUyn0TJvKNNBJtltsSRiZTj+cILZYzKXYNBu2puufIVfA+mY6OdQVKkIganMEuaVMYw3iuLvvzn6+lwej+8HT+O9hf7Pf0s'></script>
<script type='text/javascript'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<iframe src='https://widgets.wp.com/likes/master.html?ver=20210818#ver=20210818&amp;origin=https://chuttenblog.wordpress.com' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'>
		<div class="likes-text">
			<span>%d</span> bloggers like this:		</div>
		<ul class="wpl-avatars sd-like-gravatars"></ul>
	</div>
	
		<script src="//stats.wp.com/w.js?62" defer></script> <script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'102555580','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'102555580','v':'wpcom','tz':'-4','user_id':'0','post':'6090','subd':'chuttenblog'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9CSi1tXWVrbHluQismUnV8UV1kWzR+UDkzdC9EVGRRfHMrK1lJLUtLMF9SQ3xGeGlwbzAvQltSSUw1W3Z0LDZmT3VZRV9QbGc1U3lReE9UT3dGfE5vLWRfJi5Pb1Bicy5vR2MxbjF8UlctfGpuN2UsbzhCLjgzfixiM2UsWFBbLTk1N0RsRXp8d11iQThIfHBUWT9IYTZKTWtfcE1YcUIwRDRRcHN3aTJqU3pselhyS3lXc0JYXzA9LTI1cyV+M1tUcUNEK3x2bWt2X25pUzdMRFpuMw=='}]);
_stq.push([ 'clickTrackerInit', '102555580', '6090' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:1px;width:1px;overflow:hidden;position:absolute;bottom:1px;" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
