<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://chuttenblog.wordpress.com/xmlrpc.php">

<title>This Week in Glean: How Much Does That Data Cost? &#8211; chuttenblog</title>
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel='dns-prefetch' href='//a.teads.tv' />
<link rel='dns-prefetch' href='//prebid.media.net' />
<link rel='dns-prefetch' href='//adserver-us.adtech.advertising.com' />
<link rel='dns-prefetch' href='//fastlane.rubiconproject.com' />
<link rel='dns-prefetch' href='//prebid-server.rubiconproject.com' />
<link rel='dns-prefetch' href='//hb-api.omnitagjs.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//apex.go.sonobi.com' />
<link rel='dns-prefetch' href='//u.openx.net' />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Feed" href="https://chuttenblog.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Comments Feed" href="https://chuttenblog.wordpress.com/comments/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJylU9tuwjAM/aGlpsAGe5j4lqTxOkMuVZxQ8fdLG0AFNpiGKkWJfS7NqQt9JxrvIroInUktOYbPZIxgiihQUyTXitKB1eJ9lp8lNN5a70ATx+O+aphfYCKmjD/xGHoftNQMrfFKmhusTWekoR0ybDF2stmJ8XQDP2HblI8KQ5s7AWFVrasaVCKjB/eRroIMB+B4MPgHmZE1cZcHn6JoA+n/SgQ55McP6I8DL2l6jlwcSvR7wv4JUdxnfOYlF7Xv3VT5x9YTVqc8Ilk05LC4XFd/NWj8Mde6ms+qWvRdnrqiURpVCXj8+E+8ZknYZN1pGNfVe/M7TGKu207GAWGzk0SDNsPu0cYLCaW6gMwir5aSFfErE2/n/8LODtLlR4EMvKwUKoHzkTKbz5uhsbEf9ev6bTlf14vZ9hsJFH4z?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='hew-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C600italic%2C700italic%7CNoto+Serif%3A400%2C700%2C400italic%2C700italic&#038;subset=latin' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJyFj0sOwjAMRC9EsAqlrBBnSYMJBieOGkcRtyeITSt+uxnNG3+gJuMkKkaFUEzi4ilm8BhxohZ8kWuX8wpmXb1gwAypjHDBClnvjP8giu4FmpqchDd8dk+lk0fNgKWlciM0bCsohsRW28jP+xYPiWFxVkniwpgzW5p+VSccWXyTHho1s8/SMRy63WY/bPuuH64PGWR9Fw==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9jtsOgjAMhl/IWRBUvDA+S5ljVMtG1hLj2zsTiRgS04u2yfcf4DEaG4O6oDBMZuTJUxBAqxRDi+l7ba3IBhb4zHYTsxFSZ9yVlIL/uMCxOhV5avAcW8yMPtkJiKKShZYx3Femiw5jFDUdIyWQHlM2nvc/lURLOYujj7/PSqS9G3Kdfu73Bi7Dudw3h3rXlFVxewFn6WiM?cssminify=yes' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKOPT4FubmZ6UWJJql5uZh5McXJ+XklqXglIbW5+UmZOqm5pcWpRYjpQDGhQWj5QnX2uraGpqYWxqZmZqXEWALkfL7E='></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chuttenblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Distributed Teams: Not Just Working From&nbsp;Home' href='https://chuttenblog.wordpress.com/2020/03/12/distributed-teams-not-just-working-from-home/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/" />
<link rel='shortlink' href='https://wp.me/p6Wjog-1x9' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="This Week in Glean: How Much Does That Data Cost?" />
<meta property="og:url" content="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/" />
<meta property="og:description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or wh…" />
<meta property="article:published_time" content="2020-04-15T16:04:26+00:00" />
<meta property="article:modified_time" content="2020-04-15T16:04:26+00:00" />
<meta property="og:site_name" content="chuttenblog" />
<meta property="og:image" content="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png" />
<meta property="og:image:width" content="1309" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="time series plot showing data volumes from five Firefox versions" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="This Week in Glean: How Much Does That Data&nbsp;Cost?" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://chuttenblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://chuttenblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://chuttenblog.wordpress.com/osd.xml" title="chuttenblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="chuttenblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://chuttenblog.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean. You can find an index of all TWiG posts online.) I&#039;ve written&hellip;" />
		<script type="text/javascript">

			window.doNotSellCallback = function( $ ) {

				var linkElements = [
					'a[href="https://wordpress.com/?ref=footer_blog"]',
					'a[href="https://wordpress.com/?ref=footer_website"]',
					'a[href="https://wordpress.com/?ref=vertical_footer"]',
					'a[href^="https://wordpress.com/?ref=footer_segment_"]',
				].join(',');

				var dnsLink = $( '<a href="https://wordpress.com/advertising-program-optout" rel="nofollow" style="margin-left: 0.5em;">Do Not Sell My Personal Information</a>' );
				var creditLinks = $( linkElements );

				if ( 0 === creditLinks.length ) {
					return false;
				}

				creditLinks.after(dnsLink);
				return true;
			};
		</script>
				<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 0, tn: 'hew', amp: false, siteid: 8982, blogid: 102555580, consent: __ATA_CC() };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript">
		(function(){var g=Date.now||function(){return+new Date};function h(a,b){a:{for(var c=a.length,d="string"==typeof a?a.split(""):a,e=0;e<c;e++)if(e in d&&b.call(void 0,d[e],e,a)){b=e;break a}b=-1}return 0>b?null:"string"==typeof a?a.charAt(b):a[b]};function k(a,b,c){c=null!=c?"="+encodeURIComponent(String(c)):"";if(b+=c){c=a.indexOf("#");0>c&&(c=a.length);var d=a.indexOf("?");if(0>d||d>c){d=c;var e=""}else e=a.substring(d+1,c);a=[a.substr(0,d),e,a.substr(c)];c=a[1];a[1]=b?c?c+"&"+b:b:c;a=a[0]+(a[1]?"?"+a[1]:"")+a[2]}return a};var l=0;function m(a,b){var c=document.createElement("script");c.src=a;c.onload=function(){b&&b(void 0)};c.onerror=function(){b("error")};a=document.getElementsByTagName("head");var d;a&&0!==a.length?d=a[0]:d=document.documentElement;d.appendChild(c)}function n(a){var b=void 0===b?document.cookie:b;return(b=h(b.split("; "),function(c){return-1!=c.indexOf(a+"=")}))?b.split("=")[1]:""}function p(a){return"string"==typeof a&&0<a.length}
		function r(a,b,c){b=void 0===b?"":b;c=void 0===c?".":c;var d=[];Object.keys(a).forEach(function(e){var f=a[e],q=typeof f;"object"==q&&null!=f||"function"==q?d.push(r(f,b+e+c)):null!==f&&void 0!==f&&(e=encodeURIComponent(b+e),d.push(e+"="+encodeURIComponent(f)))});return d.filter(p).join("&")}function t(a,b){a||((window.__ATA||{}).config=b.c,m(b.url))}var u=Math.floor(1E13*Math.random()),v=window.__ATA||{};window.__ATA=v;v.rid=u;v.createdAt=g();var w=window.__ATA||{},x="s.pubmine.com";
		w&&w.serverDomain&&(x=w.serverDomain);var y="//"+x+"/conf",z=window.top===window,A=window.__ATA_PP&&window.__ATA_PP.gdpr_applies,B="boolean"===typeof A?Number(A):null,C=window.__ATA_PP||null,D=z?document.referrer?document.referrer:null:null,E=z?window.location.href:document.referrer?document.referrer:null,F,G=n("__ATA_tuuid");F=G?G:null;var H=window.innerWidth+"x"+window.innerHeight,I=n("usprivacy"),J=r({gdpr:B,pp:C,rid:u,src:D,ref:E,tuuid:F,vp:H,us_privacy:I?I:null},"",".");
		(function(a){var b=void 0===b?"cb":b;l++;var c="callback__"+g().toString(36)+"_"+l.toString(36);a=k(a,b,c);window[c]=function(d){t(void 0,d)};m(a,function(d){d&&t(d)})})(y+"?"+J);}).call(this);
		</script><link rel="amphtml" href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/amp/"><style type="text/css" id="custom-colors-css">.widget-title{text-shadow:none}.top-widget-area .widget_search .search-field{background-color:#fff;color:#393939}@media screen and (max-width:768px){.main-navigation a:hover,.main-navigation ul:hover>a{color:#fff !important}}body,a{color:#393939}.main-navigation ul ul{background-color:#393939}.entry-meta,.entry-meta a,.site-info,.site-info a{color:#6d6d6d}.site-main .comment-navigation a,.site-main .posts-navigation a,.site-main .post-navigation a{color:#6d6d6d}.tags-links a,.error-404 .tagcloud a{background-color:#000}.tags-links a,.error-404 .tagcloud a{background-color:rgba(0,0,0,.1)}button,input[type="button"],input[type="reset"],input[type="submit"],#infinite-handle span{color:#000}.widget ul>li,.widget ol>li{border-top-color:#000}.widget ul>li,.widget ol>li{border-top-color:rgba(0,0,0,.15)}.widget table,.widget td{border-color:#000}.widget table,.widget td{border-color:rgba(0,0,0,.15)}.top-widget-area .widget_search .search-field,.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus{border-color:#000}.top-widget-area .widget_search .search-field,.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus{border-color:rgba(0,0,0,.15)}.entry-title a:hover,.entry-title a:focus,.entry-footer .edit-link a:hover{color:#6d6d6d}.tagcloud a:hover{color:#4c4c4c}.widget a:hover,.widget a:focus{color:#cecece}.comment-meta{background-color:#6d6d6d}.widget-title{color:#fff}a[class*="tag-link-"]{background-color:#fff}a[class*="tag-link-"]{background-color:rgba(255,255,255,.25)}.widget{color:#fff}.tags-links a,.error-404 .tagcloud a{color:#999}.comment-meta a{color:#4c4c4c}body{background-color:#fff}#masthead{background-color:#c4c4c4}.entry-format,.bypostauthor .comment-meta{background-color:#c4c4c4}a:hover,a:focus,a:active{color:#6d6d6d}button,input[type="button"],input[type="reset"],input[type="submit"],#infinite-handle span{background-color:#6d6d6d}.page-links a:hover,.tags-links a:hover{background-color:#6d6d6d}.entry-content a:hover,.entry-summary a:hover,.comment-content a:hover{color:#6d6d6d}input[type="text"]:focus,input[type="email"]:focus,input[type="url"]:focus,input[type="password"]:focus,input[type="search"]:focus,textarea:focus{border-color:#6d6d6d}.widget .milestone-header{background-color:#cecece}.social-links ul a:hover:before,.toggle-button.open:before,.toggle-button:hover:before,.main-navigation.toggled .toggle-button:before{color:#c4c4c4}.widget a{color:#cecece}a[class*="tag-link-"]:hover{background-color:#cecece}.entry-content a:hover,.entry-summary a:hover,.comment-content a:hover{border-bottom-color:#6d6d6d}#widgets-wrapper{background-color:#525252}button:hover,input[type="button"]:hover,input[type="reset"]:hover,input[type="submit"]:hover,#infinite-handle span:hover{background-color:#525252}.entry-meta a:hover,.page-links a:hover,.site-info a:hover,.error-404 .widget-title{color:#525252}.comment-meta a:hover{color:#4c4c4c}.toggle-button.open,.toggle-button:hover,.toggled .menu-toggle,.social-links ul li a:hover{background-color:#4c4c4c}.site-title a,.toggle-button:before,.toggled .menu-toggle:before,.social-links ul a:before,.entry-format:before,.tags-links a:hover,.error-404 .tagcloud a:hover{color:#4c4c4c}.main-navigation a{color:#4c4c4c}.main-navigation a:hover,.main-navigation ul :hover>a{color:#525252}.main-navigation a:hover,.main-navigation ul :hover>a{color:rgba(82,82,82,.8)}.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus,{color:#4c4c4c}.widget .milestone-header,a[class*="tag-link-"]:hover{color:#4c4c4c}</style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_gat._anonymizeIp']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-5899 single-format-standard customizer-styles-applied has-sidebar has-header-image widgets-hidden highlander-enabled highlander-light">
<div id="page" class="hfeed site">
		<div id="widgets-wrapper" class="hide">
		
<div id="secondary" class="wrap top-widget-area" role="complementary">
		<div id="sidebar-1" class="widget-area" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://chuttenblog.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h1 class="widget-title">Recent Posts</h1>		<ul>
											<li>
					<a href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/" aria-current="page">This Week in Glean: How Much Does That Data&nbsp;Cost?</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2020/03/12/distributed-teams-not-just-working-from-home/">Distributed Teams: Not Just Working From&nbsp;Home</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2020/02/25/jira-bugzilla-and-tales-of-issue-trackers-past/">Jira, Bugzilla, and Tales of Issue Trackers&nbsp;Past</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2020/02/21/this-week-in-glean-a-distributed-team-echoes-distributed-workflow/">This Week in Glean: A Distributed Team Echoes Distributed&nbsp;Workflow</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2020/02/12/controlling-a-linux-laptops-internet-access/">Controlling a Linux Laptop&#8217;s Internet&nbsp;Access</a>
									</li>
					</ul>
		</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<ul>
				<li><a href='https://chuttenblog.wordpress.com/2020/04/'>April 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/03/'>March 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2020/02/'>February 2020</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/11/'>November 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/10/'>October 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/08/'>August 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/06/'>June 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/05/'>May 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/04/'>April 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/03/'>March 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2019/01/'>January 2019</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/12/'>December 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/11/'>November 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/10/'>October 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/09/'>September 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/08/'>August 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/07/'>July 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/06/'>June 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/05/'>May 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/04/'>April 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/03/'>March 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/02/'>February 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/01/'>January 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/12/'>December 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/09/'>September 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/08/'>August 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/07/'>July 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/12/'>December 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/11/'>November 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/08/'>August 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/07/'>July 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/05/'>May 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/04/'>April 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/03/'>March 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/12/'>December 2015</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/11/'>November 2015</a></li>
		</ul>
			</aside>	</div><!-- #first .widget-area -->
	
		<div id="sidebar-2" class="widget-area" role="complementary">
		<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">Pages</h1>		<ul>
			<li class="page_item page-item-1"><a href="https://chuttenblog.wordpress.com/about/">About Me</a></li>
		</ul>
			</aside><aside id="categories-5" class="widget widget_categories"><h1 class="widget-title">Categories</h1>		<ul>
				<li class="cat-item cat-item-217843"><a href="https://chuttenblog.wordpress.com/category/legislative/">legislative</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://chuttenblog.wordpress.com/category/mozilla/">mozilla</a>
</li>
	<li class="cat-item cat-item-2007"><a href="https://chuttenblog.wordpress.com/category/musings/">musings</a>
</li>
	<li class="cat-item cat-item-418349615"><a href="https://chuttenblog.wordpress.com/category/phonebg/" title="Backgrounds I set on my phone">phonebg</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://chuttenblog.wordpress.com/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</aside><aside id="rss_links-3" class="widget widget_rss_links"><h1 class="widget-title">RSS</h1><ul><li><a href="https://chuttenblog.wordpress.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://chuttenblog.wordpress.com/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</aside>	</div><!-- #second .widget-area -->
	
	
	</div><!-- #secondary -->
	</div>
	
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
					<a class="site-logo"  href="https://chuttenblog.wordpress.com/" title="chuttenblog" rel="home">
				<img src="https://secure.gravatar.com/avatar/5043f3d055047e33f78e537ded657aca/?s=80&#038;d=identicon" width="80" height="80" alt="" class="no-grav header-image" />
			</a>
		
		<div class="site-branding">
			<h1 class="site-title"><a href="https://chuttenblog.wordpress.com/" rel="home">chuttenblog</a></h1>
			<h2 class="site-description"></h2>
		</div>

		
		
				<div class="toggle-wrapper">
			<a href="#" class="widgets-toggle toggle-button" title="Widgets">
				<span class="screen-reader-text">Widgets</span>
			</a>
		</div>
		
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-5899" class="post-5899 post type-post status-publish format-standard hentry category-mozilla tag-data tag-data-science tag-firefox tag-glean tag-money tag-the-great-thing-about-having-so-many-people-review-this-was-how-each-of-them-found-a-different-part-where-costs-in-the-real-world-just-explode tag-this-week-in-glean tag-work">
	<div class="entry-wrapper">

		
		<header class="entry-header">
					<span class="entry-format theme-genericon"></span>
	
			<div class="entry-meta">
				<span class="posted-on">Posted on <a href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/" rel="bookmark"><time class="entry-date published updated" datetime="2020-04-15T12:04:26-04:00">2020-04-15</time></a></span><span class="categories"> in <a href="https://chuttenblog.wordpress.com/category/mozilla/" rel="category tag">mozilla</a></span>			</div><!-- .entry-meta -->

							<h1 class="entry-title">This Week in Glean: How Much Does That Data&nbsp;Cost?</h1>					</header><!-- .entry-header -->

		<div class="entry-content">
			<p>(“This Week in Glean” is a series of blog posts that the Glean Team at Mozilla is using to try to communicate better about our work. They could be release notes, documentation, hopes, dreams, or whatever: so long as it is inspired by Glean. You can find an <a href="https://mozilla.github.io/glean/book/appendix/twig.html">index of all TWiG posts online</a>.)</p>
<p>I&#8217;ve <a href="https://chuttenblog.wordpress.com/tag/data/">written before</a> about data, but never tackled the business perspective. To a business, what is data? It could be considered an asset, I suppose: a tool, like a printer, to make your business more efficient.</p>
<p>But like that printer and other assets, data has a cost. We can quite easily look up how much it costs to store arbitrary data on AWS (<a href="https://aws.amazon.com/s3/pricing/">less than 2.3 cents USD per GB per month</a>) but that only provides the cost of the data at rest. It doesn&#8217;t consider what it took for the data to get there or how much it costs to be useful once it&#8217;s stored.</p>
<p>So let&#8217;s imagine that you come across a decision that can only be made with data. You&#8217;ve tried your best to do without it, but you really do need to know how many Live Bookmarks there are per Firefox profile&#8230; maybe it&#8217;s in wide use and we should assign someone to spruce it up. Maybe almost no one uses it and so <a href="https://support.mozilla.org/kb/live-bookmarks-migration">Live Bookmarks should be removed</a> and instead become a feature <a href="https://addons.mozilla.org/firefox/collections/5975439/feed-readers/">provided by extensions</a>.</p>
<p>This should be easy, right? Slap the number into an HTTP payload and send it to a Mozilla-controlled server. Then just count them all up!</p>
<p>As one of the Data Organization&#8217;s unofficial mottos puts it: Counting is Harder Than It Looks.</p>
<p>Let&#8217;s look at the full lifecycle of the metric from ideation and instrumentation to expiry and deletion. I&#8217;ll measure money and time costs, being clear about the assumptions guiding my estimates and linking to sources where available.</p>
<p>For a rule of thumb, time costs are $50 per hour. Developers and Managers and PMs cost more than $100k per year in total compensation in many jurisdictions, and less in many others. Let&#8217;s go with this because why not. I considered ignoring labour costs altogether because these people are doing their jobs whether they&#8217;re performing their part in this collection or not&#8230; but that&#8217;s assuming they have the spare capacity and would otherwise be doing nothing. Everyone I talk to is busy, so everyone&#8217;s doing this data collection work instead of something else they could be doing: so there is an opportunity cost.</p>
<p>Fixed costs, like the cost of building and maintaining a data collection library, data collection pipeline, bug trackers, code review tooling, dev computers are all ignored. We could amortize that per data collection&#8230; but it&#8217;d probably work out to $0 anyway.</p>
<p>Also, for the purposes of measuring data we’re counting only the size of the data itself (the count of the number of Live Bookmarks). To be more complete we’d need to amortize the cost of sending the data point (HTTP headers, payload metadata, the data point’s identifier, etc.) and factor in additional complexity (transfer encoding, compression, etc.). This would require a lot of words, and in the present Firefox Telemetry system this amortizes to 0 because the “main” ping has many data points in it and gzip compression is pretty good.</p>
<p>Also, this is a Best Case Estimate. I make many assumptions small in order to make this a lower-bound cost if everything goes according to plan and everyone acts the way they should.</p>
<h2><b>Ideation &#8211; Time: 30min, Cost: $25</b></h2>
<p>How long does it take you to figure out how to measure something? You need to know the feature you&#8217;re measuring, the capabilities of the data collection library you&#8217;re using to do the measuring, and some idea of how you&#8217;ll analyse it at the other end.  If you&#8217;re trying to send something clever like the state of a customizable UI element or do something that requires custom analysis, this will take longer and take more people which will cost more money.</p>
<p>But for our example we know what we&#8217;re collecting: numbers of things. The data collection library is old and well understood. The analysis is straightforward. This takes one person a half hour to think through.</p>
<h2><b>Instrumentation &#8211; Time: 60min, Cost: $50</b></h2>
<p>Knowing the feature is not the same as knowing the code. You need a subject matter expert (developer who knows the feature and the code as well as the data collection library&#8217;s API) to figure out on exactly which line of code we should call exactly what method with exactly which count. If it&#8217;s complicated, several people may need to meet in order to figure out what to do here: are the <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1235908">input event timestamps the same format on Windows and Mac</a>? Does time when the computer is asleep <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1204823">count or not</a>?</p>
<p>For our example we have questions: Should we count the number of Live Bookmarks in the database? The number in the Bookmark Menu? The Bookmark Toolbar? What if the user deletes one, should we count before or after the delete?</p>
<p>This is small enough that we can find a single subject matter expert who knows it all. They read some documentation, make some decisions, write some code, and take an hour to do this themselves.</p>
<h2><b>Review &#8211; Time: 30min, Cost $25</b></h2>
<p>Both the <a href="https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Code_Review_FAQ">code</a> and the <a href="https://wiki.mozilla.org/Firefox/Data_Collection">data collection</a> need review. The simplicity of the data collection and the code make this quick. Mozilla&#8217;s code review tooling helps a lot here, too. Though it takes a day or two for the <a href="https://wiki.mozilla.org/Modules/All">Module Peer</a> and the <a href="https://wiki.mozilla.org/Firefox/Data_Collection">Data Steward</a> to find time to get to the reviews, it only takes a combination of a half hour for them to okay it to ship.</p>
<h2><b>Storage (user) &#8211; Cost: $0</b></h2>
<p>Data takes up space. Its <a href="https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Scalars.yaml">definition</a> takes up some bytes in the Firefox binary that you installed. It takes up bytes in your computer&#8217;s memory. It takes up bytes on disk while it waits to be sent and afterwards so you can look at it if you type <code>about:telemetry</code> into your address bar. (Try it yourself!)</p>
<p>The marginal cost to the user of the tens of bytes of memory and disk from our single number of Live Bookmarks is most accurately represented as a zero not only because memory and disk are excitingly cheap these days but also because there was likely some spare capacity in those systems.</p>
<h2><b>Bandwidth (user) &#8211; Cost: $0.00 (but not zero)<br />
</b></h2>
<p>Data requires network bandwidth to be reported, and network bandwidth costs money. Many consumer plans are flat-rate and so the marginal cost of the extra bytes is not felt at all (we&#8217;re using a little of the slack), so we can flatten this to zero.</p>
<p>But hey, let&#8217;s do some recreational math for fun! (We all do this in our spare time, right? It&#8217;s not just me?)</p>
<p>If we were paying per-byte and sending this from a smartphone, the first GB in Canada (<a href="https://dailyhive.com/vancouver/canada-wireless-companies-most-revenue-tefficient-2019">where mobile data makes the most money for the service providers in the world</a>) costs $30 per month. That&#8217;s about 3 thousandths of a cent per kilobyte.</p>
<p>The data collection is a number, which is about 4 bytes of data. We send it about three times per day and individual profiles are in use by Firefox on average 12 days a month (engagement ratio of 0.4). (If you&#8217;re interested, this is due to a bunch of factors including users having multiple profiles at school, work, and home&#8230; but that&#8217;s another blog post).</p>
<pre>4 bytes x 3 per day x 12 days in a month ~= 144 bytes per month</pre>
<p>Thus a more accurate cost estimate of user bandwidth for this data would be 4 ten-thousandths of a cent (in Canadian dollars). It would take over 200 years of reporting this figure to cost the user a single penny. So let&#8217;s call it 0 for our purposes here.</p>
<p>Though… however close the cost is to 0, It isn’t 0. This means that, over time and over enough data points and over our full Firefox population, there is a measurable cost. Though its weight is light when it is but a single data point sent infrequently by each of our users, put together it is still hefty enough that we shouldn’t ignore it.</p>
<h2><b>Bandwidth (Mozilla) &#8211; Cost: $0</b></h2>
<p>Internet Service Providers have a nice gig: they can charge the user when the bytes leave their machine and charge Mozilla when the bytes enter their machine. However, cloud data platform providers (Amazon&#8217;s AWS, Google&#8217;s GCP, Microsoft&#8217;s Azure, etc) don&#8217;t charge for bandwidth for the data coming into their services.</p>
<p>You do get charged for bandwidth _leaving_ their systems. And for anything you do _on_ their systems. If I were feeling uncharitable I guess I&#8217;d call this a vendor lock-in data roach motel.</p>
<p>At any rate, the cost for this step is 0.</p>
<h2><b>Pipeline Processing &#8211; Cost: $15.12</b></h2>
<p>Once our Live Bookmarks data reaches the pipeline, there&#8217;s a few steps the data needs to go through. It needs to be decompressed, examined for adherence to the data schema (malformed data gets thrown out), and a response written to the client to tell it that we received it all okay. It needs to be processed, examined, and funneled to the correct storage locations while also being made available for realtime analysis if we need it.</p>
<p>For our little 4-byte number that shouldn&#8217;t be too bad, right?</p>
<p>Well, now that we&#8217;re on Mozilla&#8217;s side of the operation we need to consider the scale. Just how many Firefox profiles are sending how many of these numbers at us? <a href="https://data.firefox.com/dashboard/user-activity">About 250M of them each month</a>. (At time of writing this isn&#8217;t up-to-date beyond EOY2019. Sorry about that. We&#8217;re working on it). With an engagement ratio of about 0.4, data being sent about thrice a day, and each count of Live Bookmarks taking up 4 bytes of space, we&#8217;re looking at 12GB of data per month.</p>
<p>At our present levels, ingestion and processing costs about $90 per TB. This comes out to $1.08 of cost for this step, each month. Multiplied by 14 &#8220;months&#8221;, that&#8217;s $15.12.</p>
<h4><b>About Months</b></h4>
<p>In saying &#8220;14 months&#8221; for how long the pipeline needs to put up with the collection coming from the entire Firefox population I glossed over quite a lot of detail. The main piece of information is that the default expiry for new data collections in Firefox is five or six Firefox versions (which should come out to about six months).</p>
<p>However, as I&#8217;ve <a href="https://chuttenblog.wordpress.com/2018/06/27/when-exactly-does-a-firefox-user-update-anyway/">mentioned</a><a href="https://chuttenblog.wordpress.com/2018/07/06/when-do-all-firefox-users-update/"> before</a>, updates don&#8217;t all happen at once. Though we have about <a href="https://telemetry.mozilla.org/update-orphaning/">90% of the Firefox population within 3 versions of up-to-date</a> at any one time, there&#8217;s a long tail of Firefox profiles from ancient versions sending us data.</p>
<p>To calculate 14 months I looked at the total data collection volumes for five versions of Firefox: Firefox 69-73 (inclusive). This avoids Firefox ESR 68 gumming up the works (its support lifetime is much longer than a normal release, and we&#8217;re aiming for a best-case cost estimate) and is both far enough in the past that Firefox 69 ought to be winding down around now _and_ is recent enough that we&#8217;ll not have thrown out the data yet (more on retention periods later) and it is closer in behaviour to releases we&#8217;re doing this year.</p>
<p>Here&#8217;s what that looks like:<img data-attachment-id="5935" data-permalink="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/screenshot_2020-04-09-pings-per-day-from-five-versions/" data-orig-file="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png" data-orig-size="1309,400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2020-04-09 Pings per Day From Five Versions" data-image-description="" data-medium-file="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=300" data-large-file="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=984" class="alignnone size-full wp-image-5935" src="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=984" alt="time series plot showing data volumes from five Firefox versions" srcset="https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=984 984w, https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=150 150w, https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=300 300w, https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=768 768w, https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png?w=1024 1024w, https://chuttenblog.files.wordpress.com/2020/04/screenshot_2020-04-09-pings-per-day-from-five-versions.png 1309w" sizes="(max-width: 984px) 100vw, 984px"   /></p>
<p>So I said this was far enough in the past that Firefox 69 ought to be winding down around now? Well, if you look really closely at the bottom-right you might be able to see that we&#8217;re still receiving data from users still on that Firefox version. Lots of them.</p>
<p>But this is where we are in history, and I&#8217;m not running this query again (it only cost 15 cents, but it took half an hour), so let&#8217;s do the math. The total amount of data received from these five releases so far divided by the amount of data I said above that the user population would be sending each month (12GB) comes out to about 13.7 months.</p>
<p>To account for the seriously-annoying number of pings from those five versions that we presumably will continue receiving into the future, I rounded up to 14.</p>
<h2><b>Storage (Mozilla) &#8211; Cost: $84</b></h2>
<p>Once the data has been processed it needs to live somewhere. This costs us 2 cents per gigabyte stored, per month we decide to store it. 12GB per month means $0.24, right?</p>
<p>Well, no. We don&#8217;t have a way to only store this data for a period of time, so we need to store it for as long as the other stuff we store. For year-over-year forecasting we retain data for two years plus one month: 25 months. (Well, we presently retain data a bit longer than that, but we’re getting there.) So we need to take the 12GB we get each month and store it for 25 months. When we do that for each of the 14 &#8220;months&#8221; of data we get:</p>
<pre>12GB/”month” x 14 “months” x $0.02 per GB per month x 25 months retention = $84</pre>
<p>Now if you think this &#8220;2 cents per GB&#8221; figure is a little high: it is! We should be able to take advantage of lower storage costs for data we don&#8217;t write to any more. Unfortunately, we do write to it all the time servicing Deletion Requests (which I&#8217;ll get to in a little bit).</p>
<h2><b>Analysis (Mozilla) &#8211; Time: 30min, Cost: $25.55</b></h2>
<p>Data stored on some server someplace is of no use. Its value is derived through interrogating it, faceting its aggregations across interesting dimensions, picking it apart and putting it back together.</p>
<p>If this sounds like processing time Mozilla needs to pay for, you are correct!</p>
<p>On-demand analyses in Google&#8217;s BigQuery cost <a href="https://cloud.google.com/bigquery/pricing#on_demand_pricing">$5 per TB of data scanned</a>. Mozilla&#8217;s spent some decent time thinking about query patterns to arrange data in a way that minimizes the amount of data we need to look at in any given analysis&#8230; but it isn&#8217;t perfect. To deliver us a count of the number of Live Bookmarks across our user base we&#8217;re going to have to scan more than the 12GB per month.</p>
<p>But this is a Best Case Estimate so let&#8217;s figure out how much a perfect query (one that only had to scan the data we wanted to get out of it) would cost:</p>
<pre>12GB / 1000GB/TB * 5 $/TB = $0.06</pre>
<p>That gives you back a sum of all the Live Bookmarks reported from all the Firefox profiles in a month. The number might be 5, or 5 million, or 5 trillion.</p>
<p>In other words, the number is useless. The real question you want to answer is &#8220;How much is this feature used?&#8221; which is less about the number of Live Bookmarks reported than it is Live Bookmarks stored <em>per Firefox profile</em>. If the 5 million Live Bookmarks are five thousand reports of 1000 Live Bookmarks all from <a href="https://twitter.com/osunick?lang=en">one fellow named Nick</a>, then we shouldn&#8217;t be investing in a feature used by one person, however much that one person uses it.</p>
<p>If the 5 million Live Bookmarks are one hundred thousand profiles reporting various handfuls of times a moderate number of bookmarks, then Live Bookmarks is more likely a broadly-used feature and might just need a little kick to be used even more.</p>
<p>So we need to aggregate the counts per-client and then look at the distribution. We can ask, over all the reports of Live Bookmarks from this one Firefox profile, give us the maximum number reported. Then show us a graph (<a href="https://mzl.la/3aXUqHR">like this</a>). A perfect query of a month&#8217;s data will not only need to look at the 12GB of the month&#8217;s Live Bookmarks count, but also the profile identifier (client_id) so we can deduplicate reports. That id is a<a href="https://en.wikipedia.org/wiki/Universally_unique_identifier#Format"> UUID</a> and is represented as a 36-byte string. This adds another 8x data to scan compared to the 4B Live Bookmarks count we were previously looking at, ballooning our query to 108GB and our cost to $0.54.</p>
<p>But wait! We&#8217;re doing two steps: one to crunch these down to the 250M profiles that reported data that month and then a second to count the counts (to make our graph). That second step needs to scan the 250M 4B &#8220;maximum counts&#8221;, which adds another half a cent.</p>
<p>So our Best Case Estimate for querying the data to get the answer to our question is: $0.55 cents (I rounded up the half cent).</p>
<p>But don&#8217;t forget you need an analyst to perform this analysis! Assuming you have a mature suite of data analysis tooling, some rigorous documentation, and a well-entrenched culture of everyone helping everyone, this shouldn&#8217;t take longer than a half-hour of a single person&#8217;s time. Which is another $25, coming to a grand total of $25.55.</p>
<h2><b>Deletion &#8211; Cost: $21</b></h2>
<p>The data&#8217;s journey is not complete because any time a user opts their Firefox profile out of data collection we receive an order to delete what data we&#8217;ve previously received from that profile. To delete we need to copy out all the not-deleted data into new partitions and drop the old ones. This is a processing cost that is currently using the ad hoc $5/TB rate every time we process a batch of deletions (monthly).</p>
<p>Our Live Bookmarks count is adding 4 bytes of data per row that needs to be copied over. Each of those counts (excepting the ones that are deleted) needs to be copied over 25 times (retention period of 25 months). The amount of deleted data is small (Firefox’s data collection is very specifically designed to <a href="https://blog.mozilla.org/firefox/firefox-data-privacy-promise/">only collect what is necessary</a>, so you shouldn’t ever feel as though you need to opt out and trigger deletion) so we’ll ignore its effect on the numbers for the purposes of making this easier to calculate.</p>
<pre>12 GB/”month” x 14 “months” x 25 deletions / 1000GB/TB x 5 $/TB = $21</pre>
<p>The total lifetime cost of all the deletion batches we process for the Live Bookmarks counts we record is $21. We’re hoping to knock this down a few pegs in cost, but it’ll probably remain in the “some dollars” order of magnitude.</p>
<p>The bigger share of this cost is actually in Storage, above. If we didn’t have to delete our data then, after 90 days, storage costs drop by half per month. This means that, if you want to assign the dollars a little more like blame, Storage costs are &#8220;only&#8221; $52.08 (full price for 3 months, half for 22) and Deletion costs are $52.92.</p>
<h2><b>Grand Total: $245.67</b></h2>
<p>In the best case, a collection of a single number from the wide Firefox user base will cost Mozilla almost $246 over the collection&#8217;s lifetime, split about 50% between labour and data computing platform costs.</p>
<p>So that&#8217;s it? Call it a wrap? Well&#8230; no. There are some cautionary tales to be learned here.</p>
<h2><b>Lessons</b></h2>
<p>0) <a href="https://leandatapractices.org">Lean Data Practices</a> save money. Our <a href="https://github.com/mozilla/data-review/blob/master/request.md">Data Collection Review Request form </a>ensures that we aren’t adding these costs to Mozilla and our users without justifying that the collection is necessary. These practices were put into place to protect our users’ privacy, but they do an equally good job of reducing costs.</p>
<p>1) The simplest <i>permanent</i> data collection costs $228 its first year and $103 every year afterwards even if you never look at it again. It costs $25 (30min) to expire a collection, which pays for itself in a maximum of 2.9 months (the payback period is much shorter if the data collection is bigger than 4B (like a Histogram) because the yearly costs are higher). The best time to have expired that collection was ages ago: the second-best time is now.</p>
<p>2) Spending extra time thinking about a data collection saves you time and money. Even if you uplift a quick expiry patch for a mis-measured collection, the nature of Firefox releases is such that you would still end up paying nearly all of the same $245.67 for a useless collection as you would for a correct one. Spend the time ahead of time to save the expense. Especially for permanent collections.</p>
<p>3) Even small improvements in documentation, process, and tooling will result in large savings. Half of this cost is labour, and lesson #2 is recommending you spend more time on it. Good documentation enables good decisions to be made confidently. Process protects you from collecting the wrong thing. Tooling catches mistakes before they make their way out into the wild. Even small things like consistent naming and language will save time and protect you from mistakes. These are your force multipliers.</p>
<p>4) To reduce costs, efficient data representations matter, and quickly-expiring data collections matter more.</p>
<p>5) Retention periods should be set as short as possible. You shouldn&#8217;t have to store Live Bookmarks counts from 2+ years ago.</p>
<h2><b>Where Does Glean Fit In</b></h2>
<p><a href="https://mozilla.github.io/glean/book/index.html">Glean</a>&#8216;s focus on high-level metric types, end-to-end-testable data collections, and consistent naming makes mistakes in instrumentation easier to find during development. Rather than waiting for instrumentation code to reach release before realizing it isn’t correct, Glean is designed to help you catch those errors earlier.</p>
<p>Also, Glean’s use of per-application identifiers and emphasis on custom pings allows for data segregation that allows for different retention periods per-application or per-feature (e.g. the &#8220;metrics&#8221; ping might not need to be retained for 25 months even if the &#8220;baseline&#8221; ping does. And Firefox Desktop&#8217;s retention periods could be configured to be of a different length than <a href="https://www.mozilla.org/firefox/lockwise/">Firefox Lockwise</a>&#8216;s) and reduces data scanned per analysis. And a consistent ping format and continued involvement of Data Science through design and development reduces analyst labour costs.</p>
<p>Basically the only thing we didn&#8217;t address was efficient data transfer encodings, and since Glean controls its ping format as an internal detail (unlike Telemetry) we could decide to address that later on without troubling Product Developers or Data Science.</p>
<p>There&#8217;s no doubt more we could do (and if you come up with something, do<a href="https://chat.mozilla.org/#/room/#glean:mozilla.org"> let us know</a>!), but already I&#8217;m confident Glean will be worth its weight in Canadian Dollars.</p>
<p>:chutten</p>
<p>(( Special thanks to :jason and :mreid for helping me nail down costs for the pipeline pieces and for the broader audience of Data Engineers, Data Scientists, Telemetry Engineers, and other folks who reviewed the draft. ))</p>
<div id="atatags-370373-5e973d490c468">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-370373-5e973d490c468', {
                    sectionId: '370373',
                    format: 'inread'
                });
            });
        </script>
    </div>			<div id="atatags-26942-5e973d490c572"></div>
			
			<script>
				__ATA.cmd.push(function() {
					__ATA.initDynamicSlot({
						id: 'atatags-26942-5e973d490c572',
						location: 120,
						formFactor: '001',
						label: {
							text: 'Advertisements',
						},
						creative: {
							reportAd: {
								text: 'Report this ad',
							},
							privacySettings: {
								text: 'Privacy settings',
							}
						}
					});
				});
			</script><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-5899" class="share-twitter sd-button share-icon" href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-5899" class="share-facebook sd-button share-icon" href="https://chuttenblog.wordpress.com/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-102555580-5899-5e973d490cb95' data-src='//widgets.wp.com/likes/index.html?ver=20190321#blog_id=102555580&amp;post_id=5899&amp;origin=chuttenblog.wordpress.com&amp;obj_id=102555580-5899-5e973d490cb95' data-name='like-post-frame-102555580-5899-5e973d490cb95'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

			<footer class="entry-footer">
					<span class="tags-links"><a href="https://chuttenblog.wordpress.com/tag/data/" rel="tag">data</a> <a href="https://chuttenblog.wordpress.com/tag/data-science/" rel="tag">data science</a> <a href="https://chuttenblog.wordpress.com/tag/firefox/" rel="tag">firefox</a> <a href="https://chuttenblog.wordpress.com/tag/glean/" rel="tag">glean</a> <a href="https://chuttenblog.wordpress.com/tag/money/" rel="tag">money</a> <a href="https://chuttenblog.wordpress.com/tag/the-great-thing-about-having-so-many-people-review-this-was-how-each-of-them-found-a-different-part-where-costs-in-the-real-world-just-explode/" rel="tag">the great thing about having so many people review this was how each of them found a different part where costs in the Real World just explode</a> <a href="https://chuttenblog.wordpress.com/tag/this-week-in-glean/" rel="tag">this week in glean</a> <a href="https://chuttenblog.wordpress.com/tag/work/" rel="tag">work</a></span>		
			</footer><!-- .entry-footer -->
		</div><!-- .entry-wrapper -->
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://chuttenblog.wordpress.com/2020/03/12/distributed-teams-not-just-working-from-home/" rel="prev">Distributed Teams: Not Just Working From&nbsp;Home</a></div></div>
	</nav>
			
		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer wrap" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_website" rel="nofollow">Create a free website or blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202016y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
			<!-- CCPA [start] -->
			<script type="text/javascript">
				( function () {

					var setupPrivacy = function() {

						var $ = window.jQuery;
						if ( ! $ ) return; // jQuery required

						$( document ).ready( function() {

							// Minimal Mozilla Cookie library
							// https://developer.mozilla.org/en-US/docs/Web/API/Document/cookie/Simple_document.cookie_framework
							var cookieLib = {getItem:function(e){return e&&decodeURIComponent(document.cookie.replace(new RegExp("(?:(?:^|.*;)\\s*"+encodeURIComponent(e).replace(/[\-\.\+\*]/g,"\\$&")+"\\s*\\=\\s*([^;]*).*$)|^.*$"),"$1"))||null},setItem:function(e,o,n,t,r,i){if(!e||/^(?:expires|max\-age|path|domain|secure)$/i.test(e))return!1;var c="";if(n)switch(n.constructor){case Number:c=n===1/0?"; expires=Fri, 31 Dec 9999 23:59:59 GMT":"; max-age="+n;break;case String:c="; expires="+n;break;case Date:c="; expires="+n.toUTCString()}return"rootDomain"!==r&&".rootDomain"!==r||(r=(".rootDomain"===r?".":"")+document.location.hostname.split(".").slice(-2).join(".")),document.cookie=encodeURIComponent(e)+"="+encodeURIComponent(o)+c+(r?"; domain="+r:"")+(t?"; path="+t:"")+(i?"; secure":""),!0}};

							var setDefaultOptInCookie = function() {
								var value = '1YNN';
								cookieLib.setItem( 'usprivacy', value, 365 * 24 * 60 * 60, '/', '.rootDomain' );
							};

							var setCcpaAppliesCookie = function( value ) {
								cookieLib.setItem( 'ccpa_applies', value, 24 * 60 * 60, '/', '.rootDomain' );
							}

							var maybeCallDoNotSellCallback = function() {
								if ( 'function' === typeof window.doNotSellCallback ) {
									return window.doNotSellCallback( $ );
								}

								return false;
							}

							var usprivacyCookie = cookieLib.getItem( 'usprivacy' );

							if ( null !== usprivacyCookie ) {
								maybeCallDoNotSellCallback();
								return;
							}

							var ccpaCookie = cookieLib.getItem( 'ccpa_applies' );

							if ( null === ccpaCookie ) {
								$.ajax({
									type: 'GET',
									dataType: "json",
									cache: false,
									url: 'https://public-api.wordpress.com/geo/',
									success: function( data ) {
										var ccpa_applies = data['region'] && data['region'].toLowerCase() === 'california';

										setCcpaAppliesCookie( ccpa_applies );

										if ( ccpa_applies ) {
											if ( maybeCallDoNotSellCallback() ) {
												setDefaultOptInCookie();
											}
										}
									},
									error: function() {
										setCcpaAppliesCookie( true );
										if ( maybeCallDoNotSellCallback() ) {
											setDefaultOptInCookie();
										}
									},
								} );
							} else {
								if ( ccpaCookie === 'true' ) {
									if ( maybeCallDoNotSellCallback() ) {
										setDefaultOptInCookie();
									}
								}
							}
						} );
					};

					if ( window.defQueue && defQueue.isLOHP && defQueue.isLOHP === 2020 ) {
						defQueue.items.push( setupPrivacy );
					} else {
						setupPrivacy();
					}

				} )();
			</script>
			<!-- CCPA [end] -->
					<script type="text/javascript">
			( function( $ ) {
				$( document.body ).on( 'post-load', function () {
					if ( typeof __ATA.insertInlineAds === 'function' ) {
						__ATA.insertInlineAds();
					}
				} );
			} )( jQuery );
			</script>
	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="102555580" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://chuttenblog.wordpress.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="chuttenblog" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="cdb66d1d1c" /><input type="hidden" name="_wp_http_referer" value="/2020/04/15/this-week-in-glean-how-much-does-that-data-cost/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chuttenblog.wordpress.com\/2020\/04\/15\/this-week-in-glean-how-much-does-that-data-cost\/":5899};
	</script>
				<div class="widget widget_eu_cookie_law_widget"><div
	class="hide-on-button ads-active"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />

		Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://automattic.com/cookies" >
			Cookie Policy		</a>
 </form>
</div>
</div><link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/_static/??/wp-content/plugins/gutenberg-blocks/jetpack-layout-grid/blocks/front.css,/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1583834955j&cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script>
var actionbardata = {"siteID":"102555580","siteName":"chuttenblog","siteURL":"http:\/\/chuttenblog.wordpress.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/hew","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F&signup_flow=account","themeURL":"https:\/\/wordpress.com\/theme\/hew\/","xhrURL":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"c293e58c23","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"fa5e588caf\" \/>","referer":"https:\/\/chuttenblog.wordpress.com\/2020\/04\/15\/this-week-in-glean-how-much-does-that-data-cost\/","canFollow":"1","feedID":"40067007","statusMessage":"","customizeLink":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F","postID":"5899","shortlink":"https:\/\/wp.me\/p6Wjog-1x9","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/chuttenblog.wordpress.com\/5899","statsLink":"https:\/\/wordpress.com\/stats\/post\/5899\/chuttenblog.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Hew","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 25 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F&signup_flow=account\">Log in now.<\/a>","stats":"Stats"}};
</script>
<script>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"733ec8b744","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/chuttenblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2020%2F04%2F15%2Fthis-week-in-glean-how-much-does-that-data-cost%2F","blog_id":"102555580","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=102555580&v=wpcom&tz=-4&user_id=0&subd=chuttenblog","is_public":"1","reblog_enabled":""};
</script>
<script>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydU2FTgzAM/UN23dzU+cHzt5QSIFDa2rTg/PW2MiYDbp47PjT3kpd7CS+8t0wa7UF7XhPPoUMJ9nNT0wO/TllDvgUiUcKYRS1VyIF+mEied6Bz41LKGnUqUKlNi3rezKpQoiZeBKUYoQcGOXrUJRsy/GX/uo3fgUvTtkYPvYd4RVj9EcCdzs8GdYfQ/1lWg7dCNswB4RfMy9vARpEKmzhgJAWohM4VuPvHyZSJYNwjsRjK5ry0Fb0TAWnuCLFBSJ0UZZx6tLdUL0hXwP0TQJeaSBO0z02vz2PM0Hl7X0E0Drch4xX0SU21nHhZpEWHpfC4/OnLWmrQxtl0wwojA7ECFxaebKfHvARPHELMmgaBKdFzD61VwsMMv9FH5NHdLBOOt4I8uBgx04FzmI7igv2zg3fRmIt/NCXJtJREukRrF0n29/Sm+PUhTKvWjCScCQSKjwczAjc4yeGsUAIdp0q46KPxjaT39m33dHw+PB53+239DZeSrOo='></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?m=1573572739h&#038;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?m=1540208548h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?m=1585663916h&#038;ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?m=1585663916h&#038;ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?m=1550600082h&#038;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?m=1540208548h&#038;ver=2.0.2"></scr' + 'ipt>' );
( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://s2.wp.com/wp-content/plugins/gutenberg-core/7.8.1/vendor/wp-polyfill-url.min.7490158b.js?m=1586214842h&#038;ver=3.6.4"></scr' + 'ipt>' );
( window.DOMRect ) || document.write( '<script src="https://s1.wp.com/wp-content/plugins/gutenberg-core/7.8.1/vendor/wp-polyfill-dom-rect.7e21c103.js?m=1586214842h&#038;ver=3.42.0"></scr' + 'ipt>' );
</script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20190321#ver=20190321' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?61" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'102555580','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'102555580','v':'wpcom','tz':'-4','user_id':'0','post':'5899','subd':'chuttenblog'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9CSi1tXWVrbHluQismUnV8UV1kWzR+UDkzdC9EVGRRfHMrK1lJLUtLMF9SQ3xGeGlwbzAvQm5rdDRqa001cjBoNXRQT1hPcUZKb1JvMmdCdTZwXyZRTXFOYnBlK1d8K2pNejVfUHFiWDU5SUV0UUg0OSxtUGs0QWtLd1B3bDUsXWlqXS95V3kxMitLNHc1SWc3NXxnSmtqK0F5ZW0/djFZcyssWEhQUCtacSZjRlJHVlJia3hPJlh4UlMuemdQJlZNND1iSGtsNUlkcUFCT0ZqPWVMflZ8YWRDeEtMYnF4WWF+clBpY24='}]);
_stq.push([ 'clickTrackerInit', '102555580', '5899' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated 293 seconds ago
	generated in 0.104 seconds
	served from batcache in 0.003 seconds
	expires in 7 seconds
-->
