<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://chuttenblog.wordpress.com/xmlrpc.php">

<title>Data Science is Hard: Counting Users &#8211; chuttenblog</title>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Feed" href="https://chuttenblog.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Comments Feed" href="https://chuttenblog.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="chuttenblog &raquo; Data Science is Hard: Counting&nbsp;Users Comments Feed" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1532082729h&ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJx9j9EOgyAMRX9orJuZLntY9i2AjUMpEIvx91dmZlxMfCGlPQduYU7KxpAxZKBJJT91LjB4NyBDjzlpO6jv7WyZT7DBjY/dKsxxbHXL0PlotN+xm6dtHFH6lHQuBGHrNHokwY40Ss3PKuVbcu0jbfg5Ca2MSSMyKznJTaTyWz469MQqUZadQcD/zqI6CDE7sXktyuBFz2td3e7N41LV/Qf05IFG?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='hew-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C600italic%2C700italic%7CNoto+Serif%3A400%2C700%2C400italic%2C700italic&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJyFj0sOwjAMRC9EsAqlrBBnCcGkBuejxlHE7QnqJohSdh7Nm7ENJSoTvKAXcFlFzpZ8AoseJ6rGj3FrUtpAk5URHSaI+QIjFkjyZPwHkTczqEo0wX3hzT2FrhYlAebqhgehYl1A0EXWUiuX9y0UpGBIs5r/acVa2GJQHIwWCv5DqBtrmtaiE1442DpaqFQj36GzO3WH3XHY910/3F8tKZRE?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9i0EKQjEMBS9kDdVfXIlnyS+1jaRJafLx+uJCRBRXbx7MwH2ErOJFHPoWBm+VxACzk8qK8037bLaD3/pQ83BlpAnWcJLU1/6rTDMhB9aqn+cr8lZ6MWgLVNYV+Slc+jmmQzrFtMTj7QHFQEmu?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chuttenblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ontario&#8217;s 42nd Parliament, 1st Session: July&nbsp;2018' href='https://chuttenblog.wordpress.com/2018/08/01/ontarios-42nd-parliament-1st-session-july-2018/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/" />
<link rel='shortlink' href='https://wp.me/p6Wjog-1v0' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Data Science is Hard: Counting Users" />
<meta property="og:url" content="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/" />
<meta property="og:description" content="Counting is harder than you think. No, really! Intuitively, as you look around you, you think this can&#8217;t be true. If you see a parking lot you can count the cars, right? But do cars that have…" />
<meta property="article:published_time" content="2018-08-29T14:19:53+00:00" />
<meta property="article:modified_time" content="2018-08-29T14:19:53+00:00" />
<meta property="og:site_name" content="chuttenblog" />
<meta property="og:image" content="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png" />
<meta property="og:image:width" content="1186" />
<meta property="og:image:height" content="684" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="Data Science is Hard: Counting&nbsp;Users" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://chuttenblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://chuttenblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://chuttenblog.wordpress.com/osd.xml" title="chuttenblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="chuttenblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://chuttenblog.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Counting is harder than you think. No, really! Intuitively, as you look around you, you think this can&#039;t be true. If you see a parking lot you can count the cars, right? But do cars that have left the parking lot count? What about cars driving through it without stopping? What about cars driving through&hellip;" />
		<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 0, tn: 'hew', amp: false, siteid: 8982, consent: __ATA_CC() };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript" src="//s.pubmine.com/head.js" async></script><link rel="amphtml" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">.widget-title{text-shadow:none}.top-widget-area .widget_search .search-field{background-color:#fff;color:#393939}@media screen and (max-width:768px){.main-navigation a:hover,.main-navigation ul:hover>a{color:#fff !important}}body,a{color:#393939}.main-navigation ul ul{background-color:#393939}.entry-meta,.entry-meta a,.site-info,.site-info a{color:#6d6d6d}.site-main .comment-navigation a,.site-main .posts-navigation a,.site-main .post-navigation a{color:#6d6d6d}.tags-links a,.error-404 .tagcloud a{background-color:#000}.tags-links a,.error-404 .tagcloud a{background-color:rgba(0,0,0,.1)}button,input[type="button"],input[type="reset"],input[type="submit"],#infinite-handle span{color:#000}.widget ul>li,.widget ol>li{border-top-color:#000}.widget ul>li,.widget ol>li{border-top-color:rgba(0,0,0,.15)}.widget table,.widget td{border-color:#000}.widget table,.widget td{border-color:rgba(0,0,0,.15)}.top-widget-area .widget_search .search-field,.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus{border-color:#000}.top-widget-area .widget_search .search-field,.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus{border-color:rgba(0,0,0,.15)}.entry-title a:hover,.entry-title a:focus,.entry-footer .edit-link a:hover{color:#6d6d6d}.tagcloud a:hover{color:#4c4c4c}.widget a:hover,.widget a:focus{color:#cecece}.comment-meta{background-color:#6d6d6d}.widget-title{color:#fff}a[class*="tag-link-"]{background-color:#fff}a[class*="tag-link-"]{background-color:rgba(255,255,255,.25)}.widget{color:#fff}.tags-links a,.error-404 .tagcloud a{color:#999}.comment-meta a{color:#4c4c4c}body{background-color:#fff}#masthead{background-color:#c4c4c4}.entry-format,.bypostauthor .comment-meta{background-color:#c4c4c4}a:hover,a:focus,a:active{color:#6d6d6d}button,input[type="button"],input[type="reset"],input[type="submit"],#infinite-handle span{background-color:#6d6d6d}.page-links a:hover,.tags-links a:hover{background-color:#6d6d6d}.entry-content a:hover,.entry-summary a:hover,.comment-content a:hover{color:#6d6d6d}input[type="text"]:focus,input[type="email"]:focus,input[type="url"]:focus,input[type="password"]:focus,input[type="search"]:focus,textarea:focus{border-color:#6d6d6d}.widget .milestone-header{background-color:#cecece}.social-links ul a:hover:before,.toggle-button.open:before,.toggle-button:hover:before,.main-navigation.toggled .toggle-button:before{color:#c4c4c4}.widget a{color:#cecece}a[class*="tag-link-"]:hover{background-color:#cecece}.entry-content a:hover,.entry-summary a:hover,.comment-content a:hover{border-bottom-color:#6d6d6d}#widgets-wrapper{background-color:#525252}button:hover,input[type="button"]:hover,input[type="reset"]:hover,input[type="submit"]:hover,#infinite-handle span:hover{background-color:#525252}.entry-meta a:hover,.page-links a:hover,.site-info a:hover,.error-404 .widget-title{color:#525252}.comment-meta a:hover{color:#4c4c4c}.toggle-button.open,.toggle-button:hover,.toggled .menu-toggle,.social-links ul li a:hover{background-color:#4c4c4c}.site-title a,.toggle-button:before,.toggled .menu-toggle:before,.social-links ul a:before,.entry-format:before,.tags-links a:hover,.error-404 .tagcloud a:hover{color:#4c4c4c}.main-navigation a{color:#4c4c4c}.main-navigation a:hover,.main-navigation ul :hover>a{color:#525252}.main-navigation a:hover,.main-navigation ul :hover>a{color:rgba(82,82,82,.8)}.top-widget-area input[type="text"]:focus,.top-widget-area input[type="email"]:focus,.top-widget-area input[type="url"]:focus,.top-widget-area input[type="password"]:focus,.top-widget-area input[type="search"]:focus,.top-widget-area textarea:focus,{color:#4c4c4c}.widget .milestone-header,a[class*="tag-link-"]:hover{color:#4c4c4c}</style>
<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_setDomainName', 'wordpress.com']);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="post-template-default single single-post postid-5766 single-format-standard mp6 customizer-styles-applied has-sidebar has-header-image widgets-hidden highlander-enabled highlander-light">
<div id="page" class="hfeed site">
		<div id="widgets-wrapper" class="hide">
		
<div id="secondary" class="wrap top-widget-area" role="complementary">
		<div id="sidebar-1" class="widget-area" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://chuttenblog.wordpress.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h1 class="widget-title">Recent Posts</h1>		<ul>
											<li>
					<a href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/">Data Science is Hard: Counting&nbsp;Users</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2018/08/01/ontarios-42nd-parliament-1st-session-july-2018/">Ontario&#8217;s 42nd Parliament, 1st Session: July&nbsp;2018</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2018/07/06/when-do-all-firefox-users-update/">When do All Firefox Users&nbsp;Update?</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2018/07/04/faster-event-telemetry-with-event-pings/">Faster Event Telemetry with &#8220;event&#8221; Pings</a>
									</li>
											<li>
					<a href="https://chuttenblog.wordpress.com/2018/06/29/some-more-very-satisfying-graphs/">Some More Very Satisfying&nbsp;Graphs</a>
									</li>
					</ul>
		</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<ul>
			<li><a href='https://chuttenblog.wordpress.com/2018/08/'>August 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/07/'>July 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/06/'>June 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/05/'>May 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/04/'>April 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/03/'>March 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/02/'>February 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2018/01/'>January 2018</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/12/'>December 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/09/'>September 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/08/'>August 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/07/'>July 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/12/'>December 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/11/'>November 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/08/'>August 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/07/'>July 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/05/'>May 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/04/'>April 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/03/'>March 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/12/'>December 2015</a></li>
	<li><a href='https://chuttenblog.wordpress.com/2015/11/'>November 2015</a></li>
		</ul>
		</aside>	</div><!-- #first .widget-area -->
	
		<div id="sidebar-2" class="widget-area" role="complementary">
		<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">Pages</h1>		<ul>
			<li class="page_item page-item-1"><a href="https://chuttenblog.wordpress.com/about/">About Me</a></li>
		</ul>
		</aside><aside id="categories-5" class="widget widget_categories"><h1 class="widget-title">Categories</h1>		<ul>
	<li class="cat-item cat-item-217843"><a href="https://chuttenblog.wordpress.com/category/legislative/" >legislative</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://chuttenblog.wordpress.com/category/mozilla/" >mozilla</a>
</li>
	<li class="cat-item cat-item-2007"><a href="https://chuttenblog.wordpress.com/category/musings/" >musings</a>
</li>
	<li class="cat-item cat-item-418349615"><a href="https://chuttenblog.wordpress.com/category/phonebg/" title="Backgrounds I set on my phone">phonebg</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://chuttenblog.wordpress.com/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
</aside><aside id="rss_links-3" class="widget widget_rss_links"><h1 class="widget-title">RSS</h1><ul><li><a href="https://chuttenblog.wordpress.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a href="https://chuttenblog.wordpress.com/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</aside>	</div><!-- #second .widget-area -->
	
	
	</div><!-- #secondary -->
	</div>
	
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
					<a class="site-logo"  href="https://chuttenblog.wordpress.com/" title="chuttenblog" rel="home">
				<img src="https://secure.gravatar.com/avatar/5043f3d055047e33f78e537ded657aca/?s=80&#038;d=identicon" width="80" height="80" alt="" class="no-grav header-image" />
			</a>
		
		<div class="site-branding">
			<h1 class="site-title"><a href="https://chuttenblog.wordpress.com/" rel="home">chuttenblog</a></h1>
			<h2 class="site-description"></h2>
		</div>

		
		
				<div class="toggle-wrapper">
			<a href="#" class="widgets-toggle toggle-button" title="Widgets">
				<span class="screen-reader-text">Widgets</span>
			</a>
		</div>
		
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-5766" class="post-5766 post type-post status-publish format-standard hentry category-mozilla tag-data tag-data-science tag-firefox tag-mozilla tag-obligatory-car-analogy-for-technological-mathematical-concepts tag-open-source tag-public-data">
	<div class="entry-wrapper">

		
		<header class="entry-header">
					<span class="entry-format theme-genericon"></span>
	
			<div class="entry-meta">
				<span class="posted-on">Posted on <a href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/" rel="bookmark"><time class="entry-date published updated" datetime="2018-08-29T10:19:53+00:00">2018-08-29</time></a></span><span class="categories"> in <a href="https://chuttenblog.wordpress.com/category/mozilla/" rel="category tag">mozilla</a></span>			</div><!-- .entry-meta -->

							<h1 class="entry-title">Data Science is Hard: Counting&nbsp;Users</h1>					</header><!-- .entry-header -->

		<div class="entry-content">
			<p><img data-attachment-id="5767" data-permalink="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/screenshot_2018-08-29-user-activity-firefox-public-data-report/" data-orig-file="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=984" data-orig-size="1186,684" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screenshot_2018-08-29 User Activity Firefox Public Data Report" data-image-description="" data-medium-file="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=984?w=300" data-large-file="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=984?w=984" class="alignnone size-full wp-image-5767" src="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=984" alt="Screenshot_2018-08-29 User Activity Firefox Public Data Report" srcset="https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=984 984w, https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=150 150w, https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=300 300w, https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=768 768w, https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png?w=1024 1024w, https://chuttenblog.files.wordpress.com/2018/08/screenshot_2018-08-29-user-activity-firefox-public-data-report.png 1186w" sizes="(max-width: 984px) 100vw, 984px"   /></p>
<p>Counting is harder than you think. No, really!</p>
<p>Intuitively, as you look around you, you think this can&#8217;t be true. If you see a parking lot you can count the cars, right?</p>
<p>But do cars that have left the parking lot count? What about cars driving through it without stopping? What about cars driving through looking for a space? (And can you tell the difference between those two kinds from a distance?)</p>
<p>These cars all count if you&#8217;re interested in usage. It&#8217;s all well and good to know the number of cars using your parking lot right now&#8230; but is it lower on weekends? Holidays? Are you measuring on a rainy day when fewer people take bicycles, or in the Summer when more people are on vacation? Do you need better signs or more amenities to get more drivers to stop? Are you going to have expand capacity this year, or next?</p>
<p>Yesterday we released the <a href="https://data.firefox.com/">Firefox Public Data Report</a>. Go take a look! It is the culmination of months of work of many mozillians (not me, I only contributed some early bug reports). In it you can find out how many users Firefox has, the most popular addons, and how quickly Firefox users update to the latest version. And you can choose whether to look at how these plots look for the worldwide user base or for one of the top ten (by number of Firefox users) countries individually.</p>
<p>It&#8217;s really cool.</p>
<p>The <a href="https://data.firefox.com/dashboard/user-activity">first two plots</a> are a little strange, though. They count the number of Firefox users over time&#8230; and they don&#8217;t agree. They don&#8217;t even come close!</p>
<p>For the week including August 17, 2018 the Yearly Active User (YAU) count is 861884770 (or about 862M)&#8230; but the Monthly Active User (MAU) count is 256092920 (or about 256M)!</p>
<p>That&#8217;s over 600M difference! Which one is right?</p>
<p>Well, they both are.</p>
<p>Returning to our parking lot analogy, MAU is about counting how many cars use the parking lot over a 28-day period. So, starting Feb 1, count cars. If someone you saw earlier returns the next day or after a week, don&#8217;t count them again: we only want unique cars. Then, at the end of the 28-day period, that was the MAU for Feb 28. The MAU for Mar 1 (on non-leap-years) is the same thing, but you start counting on Feb 2.</p>
<p>Similarly for YAU, but you count over the past 365 days.</p>
<p>It stands to reason that you&#8217;ll see more unique cars over the year than you will over the month: you&#8217;ll see visitors, tourists, people using the lot just once, and people who have changed jobs and haven&#8217;t been back in four months.</p>
<p>So how many of these 600M who are in the YAU but not in the MAU are gone forever? How many are coming back? We don&#8217;t know.</p>
<p>Well, we don&#8217;t know _precisely_.</p>
<p>We&#8217;ve been at the browser game for long enough to see patterns in the data. We&#8217;re in the Summer slump for MAU numbers, and we have a model for how much higher the numbers are likely to be come October. We have surveyed people of varied backgrounds and have some ideas of why people change browsers to or away from Firefox.</p>
<p>We have the no-longer users, the lapsed users, the lost-and-regained users, the tried-us-once users, the non-human users, &#8230; we have categories and rough proportions on what we think we know about our population, and how that influences how we can better make the internet better for them.</p>
<p>Ultimately, to me, it doesn&#8217;t matter <em>too</em> much. I work on Firefox, a product that hundreds of millions of people use. How many hundreds of millions doesn&#8217;t matter: we&#8217;re above the threshold that makes me feel like I&#8217;m making the world better.</p>
<p>(( Well&#8230; I say that, but it is actually my job to understand the mechanisms behind these  numbers and why they can&#8217;t be exact, so I do have a <em>bit</em> of a vested interest. And there are a myriad of technological and behavioural considerations to account for in code and in documentation and in analysis which makes it an <em>interesting</em> job. But, you know. Hundreds of millions is precise enough for my job satisfaction index. ))</p>
<p>But once again we reach the inescapable return to the central thesis. Counting is harder than you think: one of the leading candidates for the Data Team&#8217;s motto. (Others include &#8220;Well, it depends.&#8221; and &#8220;¯\_(ツ)_/¯&#8221;). And now we&#8217;re counting in the open, so you get to experience its difficulty firsthand. Go <a href="https://data.firefox.com/">have another look</a>.</p>
<p>:chutten</p>
<p>&nbsp;</p>
<div id="atatags-370373-5b872d9152d84">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-370373-5b872d9152d84', {
                    sectionId: '370373',
                    format: 'inread'
                });
            });
        </script>
    </div>		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-right:5px;margin-top:0px">
		<div id="atatags-26942-5b872d9152dd3">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-26942-5b872d9152dd3',  {
					collapseEmpty: 'before',
					sectionId: '26942',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div>		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-top:0px">
		<div id="atatags-114160-5b872d9152dd6">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-114160-5b872d9152dd6',  {
					collapseEmpty: 'before',
					sectionId: '114160',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div></div>
				
			</div>
		</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-5766" class="share-twitter sd-button share-icon" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-5766" class="share-facebook sd-button share-icon" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-5766" class="share-google-plus-1 sd-button share-icon" href="https://chuttenblog.wordpress.com/2018/08/29/data-science-is-hard-counting-users/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-102555580-5766-5b872d915376f' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=102555580&amp;post_id=5766&amp;origin=chuttenblog.wordpress.com&amp;obj_id=102555580-5766-5b872d915376f' data-name='like-post-frame-102555580-5766-5b872d915376f'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

			<footer class="entry-footer">
					<span class="tags-links"><a href="https://chuttenblog.wordpress.com/tag/data/" rel="tag">data</a> <a href="https://chuttenblog.wordpress.com/tag/data-science/" rel="tag">data science</a> <a href="https://chuttenblog.wordpress.com/tag/firefox/" rel="tag">firefox</a> <a href="https://chuttenblog.wordpress.com/tag/mozilla/" rel="tag">mozilla</a> <a href="https://chuttenblog.wordpress.com/tag/obligatory-car-analogy-for-technological-mathematical-concepts/" rel="tag">obligatory car analogy for technological/mathematical concepts</a> <a href="https://chuttenblog.wordpress.com/tag/open-source/" rel="tag">open source</a> <a href="https://chuttenblog.wordpress.com/tag/public-data/" rel="tag">public data</a></span>		
			</footer><!-- .entry-footer -->
		</div><!-- .entry-wrapper -->
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://chuttenblog.wordpress.com/2018/08/01/ontarios-42nd-parliament-1st-session-july-2018/" rel="prev">Ontario&#8217;s 42nd Parliament, 1st Session: July&nbsp;2018</a></div></div>
	</nav>
			
		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer wrap" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201835y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="102555580" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://chuttenblog.wordpress.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="chuttenblog" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="8c528f88fc" /><input type="hidden" name="_wp_http_referer" value="/2018/08/29/data-science-is-hard-counting-users/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/chuttenblog.wordpress.com\/2018\/08\/29\/data-science-is-hard-counting-users\/":5766};
	</script>
<div class="widget widget_eu_cookie_law_widget"><div
	class="hide-on-button ads-active"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />

		Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://automattic.com/cookies" >
			Cookie Policy		</a>
 </form>
</div>
</div><link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"102555580","siteName":"chuttenblog","siteURL":"http:\/\/chuttenblog.wordpress.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/hew","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/chuttenblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F","themeURL":"https:\/\/wordpress.com\/theme\/hew\/","xhrURL":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"de4826cd11","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"9fb43c8c66\" \/>","referer":"https:\/\/chuttenblog.wordpress.com\/2018\/08\/29\/data-science-is-hard-counting-users\/","canFollow":"1","feedID":"40067007","statusMessage":"","customizeLink":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F","postID":"5766","shortlink":"https:\/\/wp.me\/p6Wjog-1v0","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/chuttenblog.wordpress.com\/5766","statsLink":"https:\/\/wordpress.com\/stats\/post\/5766\/chuttenblog.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Hew","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/chuttenblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/chuttenblog.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"3ae2f09713","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/chuttenblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fchuttenblog.wordpress.com%2F2018%2F08%2F29%2Fdata-science-is-hard-counting-users%2F","blog_id":"102555580","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=102555580&v=wpcom&tz=-4&user_id=0&subd=chuttenblog","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVkt1uwjAMhV9owRpoQlxMexaTuK3b/C1O2u3tl4oVdQwVcWXr+Hx2ZAemqHTwmXyGXsDQyJri166XF1iVXFHRlpa9gOWBBD4LFerQG0tpw6yDc1VSF6if6TPIxJGegf4It2DuyFVbLGfoaJrtNTw2eRy5xczBP/bKwLEO94Nqgi6iGt5a0MSmpSxApVbDwKQsTpDJRYuZbvSNPmgce3XGBA4lU6qZCiOlxKZ2uWpPdsgJ9fBviWtIz0uZoWu2uNlrW8zlJhLZ39P7+jPS92/YrV33Lo0pFCELPeVY36UWYYOJQbJqLHIC6TCxb5dYoQ/3/vp22J+O+8Pp2P8ANWQSew=='></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "chuttenblog.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'102555580','blog_tz':'-4','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'102555580','v':'wpcom','tz':'-4','user_id':'0','post':'5766','subd':'chuttenblog'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWFnNncxc1tjZG9XVXhRREQ/V0xPZ1hKXy9CSi1tXWVrbHluQismUnV8UV1kWzR+UDkzdC9EVGRRfHMrK1lJLUtLMF9SQ3xGeGlwbzAvLnBQVzJ0TC1XNjg4RWNwV3pqem5uaUstW3Q3YWgueVhNRF95WGNXbWdYVnBpcS56akd6P2VtX2FlL1B3c2g5dTJmTHgxTHRbQ3AyTW10WjdOSmJkM28xLGtGX0pvSkM1UHdPNywmT2libHMyOUxtalFBXSVQb2JfWF82XyZ0bVE/UmZrNyVKTUFrOHdCbGJTbz9zXTZdS082NUN3WF1BVQ=='}]);
_stq.push([ 'clickTrackerInit', '102555580', '5766' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
